summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-06 10:44:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-06 10:44:28 +0100
commitdd83476244a09b2681ed84f726284947d2582fbf (patch)
treebd70cc9836dea2edf4e0ab96084611ae7417126b /media-libs/glyr/glyr-1.0.10.ebuild
parentmedia-sound/abcm2ps: bump to 8.13.3 (diff)
downloadgentoo-dd83476244a09b2681ed84f726284947d2582fbf.tar.gz
gentoo-dd83476244a09b2681ed84f726284947d2582fbf.tar.bz2
gentoo-dd83476244a09b2681ed84f726284947d2582fbf.zip
media-libs/glyr: bump to 1.0.10
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/glyr/glyr-1.0.10.ebuild')
-rw-r--r--media-libs/glyr/glyr-1.0.10.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/glyr/glyr-1.0.10.ebuild b/media-libs/glyr/glyr-1.0.10.ebuild
new file mode 100644
index 000000000000..d0df215796d3
--- /dev/null
+++ b/media-libs/glyr/glyr-1.0.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A music related metadata searchengine, both with commandline interface and C API"
+HOMEPAGE="https://github.com/sahib/glyr"
+SRC_URI="https://github.com/sahib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.10:2
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README*" # CHANGELOG is obsolete in favour of git history
+
+src_prepare() {
+ sed -i \
+ -e '/GCC_ONLY_OPT.*-s/d' \
+ -e '/FLAGS/s:-Os::' \
+ -e '/FLAGS/s:-g3::' \
+ CMakeLists.txt || die
+}