summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-19 20:41:19 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-19 20:43:41 +0200
commit899b2d09321e9b3e71ad68891b045fda4af5baa4 (patch)
treee2fd4b9848fd7ccf394269bbf237a3bc846b9dd6 /media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
parentx11-themes/qtcurve: Fix broken isnan patch (diff)
downloadgentoo-899b2d09321e9b3e71ad68891b045fda4af5baa4.tar.gz
gentoo-899b2d09321e9b3e71ad68891b045fda4af5baa4.tar.bz2
gentoo-899b2d09321e9b3e71ad68891b045fda4af5baa4.zip
media-libs/gnonlin: Stop using deprecated eclass (#587816)
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild')
-rw-r--r--media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild b/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..12a92735610b
--- /dev/null
+++ b/media-libs/gnonlin/gnonlin-1.4.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Gnonlin is a set of GStreamer elements to ease the creation of non-linear multimedia editors"
+HOMEPAGE="http://gnonlin.sourceforge.net"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/gstreamer-1.4.0:1.0
+ >=media-libs/gst-plugins-base-1.4.0:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-am-1.13
+ test? (
+ dev-libs/check
+ >=media-libs/gst-plugins-good-1.4.0:1.0 )
+" # videomixer
+
+src_configure() {
+ econf --disable-gtk-doc
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}