summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-08 18:30:28 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-08 19:08:00 +0100
commit5982000e7506e8904f55568b44903d5b511fac7d (patch)
treedd9bdef37fc50a3be41a14b52c56bd4f16a78286 /media-libs/gst-plugins-bad
parentmedia-plugins/gst-plugins-ximagesrc: version bump to 1.6.1 (diff)
downloadgentoo-5982000e7506e8904f55568b44903d5b511fac7d.tar.gz
gentoo-5982000e7506e8904f55568b44903d5b511fac7d.tar.bz2
gentoo-5982000e7506e8904f55568b44903d5b511fac7d.zip
media-libs/gst-plugins-bad: version bump to 1.6.1
Drop libSM runtime dependency, checks have been changed upstream and it is not necessary anymore. Use ${PV} for gstreamer and gst-plugins-base dependency as all releases are coordinated for a while now. Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/Manifest1
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index 9163b39faad3..26c972d6cbb4 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -3,3 +3,4 @@ DIST gst-plugins-bad-0.10.23.tar.xz 3155044 SHA256 03cf0786391c64625569072e90408
DIST gst-plugins-bad-1.2.4.tar.xz 3272824 SHA256 984c133ec9d5d705e313d9e2bbd1472b93c6567460602a9a316578925ffe2eca SHA512 4344dedb899cdc0e3bf36a3b5dd36c6091e2e2f2a7440e3831cebbd9b4463f89cc4bc2d589b0c2c806bcaeb1864a49b3c9e0e3bedc051f1f46e09a8f131f0aa9 WHIRLPOOL 98bce50e7018d7c8d442bf8c7f26f14bd719a8af5af0fde39841c4282a9e4edfeefe06ab10797826cf9b876e173dafcf2e2df86408c373e6c4d8902072cf393c
DIST gst-plugins-bad-1.4.5.tar.xz 3824936 SHA256 152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c SHA512 65d6be58957b1329420611b8e6f1eb9869420745d9165047631cdf9e45083605f37dcfaf68a288fe4252f1b3543f7f70ded9c12eab2e0ac4ac9f4c4ce9eaac7a WHIRLPOOL f5ade3f101ca82b52e7145e5ac16f5c1ab5d042415ee7753586dc6ad0942467c4c5b5b4aa6b0bc44e1ebd9c40de1964df265aa41599cb692fd32aab2b6a7acf7
DIST gst-plugins-bad-1.6.0.tar.xz 4209172 SHA256 d8ff26128d4ecd2ffeb28e14843808d2d971b09056b7cee6f08afcae01fc0f49 SHA512 1b646b9dbbb18bd37a9141ba5983f3d8448d60af80144759120f580c2f65e97f78b148e7b7494c46163942274444f4191bed1be43539551c4278c9056230efe2 WHIRLPOOL 8ef0303f15153cb460009bf962e9d0c70d0f73ce4dda0f7d6579509df26104e3c16a1a6710bae16d13c4d3dd9f5d4c1846caa9164fef5fd49c21657269a6b0c9
+DIST gst-plugins-bad-1.6.1.tar.xz 4215876 SHA256 e176a9af125f6874b3d6724aa7566a198fa225d3ece0a7ac2f2b51c57e525466 SHA512 336a449a23cc11c31fc744828746946de1107e31bd60bf1ba7e3b74d906bda691e917093d04a03249aabcdfc5af0a26ea2a04e343b2b744b1d404b0a5071bdd6 WHIRLPOOL 5cfaeef59b43c9c4fb70acb01f6cd31861e95904a618b02bcfa37afc81919239e1727f9e7da2bf2ee415c0525f3b7955289adbbf9099c9696f83128f7ffdf844
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild
new file mode 100644
index 000000000000..547dd00abd3a
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-bad"
+
+inherit eutils flag-o-matic gstreamer virtualx
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+
+IUSE="X egl gles2 +introspection opengl +orc vnc wayland"
+REQUIRED_USE="
+ egl? ( !gles2 )
+ gles2? ( !egl !opengl )
+ opengl? ( X )
+ wayland? ( egl )
+"
+
+# dtmf plugin moved from bad to good in 1.2
+# X11 is automagic for now, upstream #709530
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+
+ egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
+ gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
+ opengl? (
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}] )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-good-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ # FIXME: tests are slower than upstream expects
+ sed -e 's:/\* tcase_set_timeout.*:tcase_set_timeout (tc_chain, 5 * 60);:' \
+ -i tests/check/elements/audiomixer.c || die
+}
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable egl) \
+ $(use_enable gles2) \
+ $(use_enable opengl) \
+ $(use_enable opengl glx) \
+ $(use_enable orc) \
+ $(use_enable vnc librfb) \
+ $(use_enable X x11) \
+ $(use_enable wayland) \
+ --disable-examples \
+ --disable-debug \
+ --disable-cocoa \
+ --disable-wgl
+
+ if multilib_is_native_abi; then
+ local x
+ for x in libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ unset DISPLAY
+ Xemake check
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}