summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gst-rtsp-server
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gst-rtsp-server')
-rw-r--r--media-libs/gst-rtsp-server/Manifest2
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-0.10.8-r1.ebuild101
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild79
-rw-r--r--media-libs/gst-rtsp-server/metadata.xml5
4 files changed, 187 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
new file mode 100644
index 000000000000..a6bfbca1e916
--- /dev/null
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -0,0 +1,2 @@
+DIST gst-rtsp-0.10.8.tar.bz2 567670 SHA256 9915887cf8515bda87462c69738646afb715b597613edc7340477ccab63a6617 SHA512 c5020cffa9334b7d9c6b9dbe6f32bd4580eeee1c67689269d232e954ef9d96d8b988e3fb19da89701eae26419df0bf6de5796f7780cfbedda4c07154b1c1ebd7 WHIRLPOOL 6bd260edaef5ab003ef7176d84c46d5a94d365af51226108af9ab845d6e5910d90c721d5fd87e7fe93b141a82e5114b4c674a1d2500ef57302bf845c87f5463c
+DIST gst-rtsp-server-1.4.5.tar.xz 530724 SHA256 3089254bd31b7c1f1cf2c034a3b3551f92878f9e3cab65cef3a901a04c0f1d37 SHA512 0f7bbad94416de73abffd76f88fa051b6db4e5250486669b29b101d06a3629ccef886f2048d51d1e3b78c22393eaa86a1f44c696b25ffabc19a1c37c3e442a35 WHIRLPOOL 0a82942e3172a5d6f7699e73c41ab6cfd5c85c52153058fc38673dd347df5f67fa26229273cf29a6ef841c85ddf3ae3f37c0d5db073978c7f9d5546db9b7ce39
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-0.10.8-r1.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-0.10.8-r1.ebuild
new file mode 100644
index 000000000000..456ce1c21658
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-0.10.8-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gstreamer python-r1 vala
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="http://people.freedesktop.org/~wtay/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${PN/-server/}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="amd64 x86"
+IUSE="examples +introspection nls python static-libs test vala"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${P/-server/}"
+
+# ./configure is broken, so PYGOBJECT_REQ must be defined
+PYGOBJECT_REQ=2.11.2
+
+# FIXME: check should depend on USE=test but check is losy
+# libxml2 required in python binding
+RDEPEND="
+ >=dev-libs/glib-2.10.0:2[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:2[python,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
+ >=dev-python/pygobject-${PYGOBJECT_REQ}:2[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-0.10.29:0.10[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-0.10.29:0.10[introspection?,${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ python? ( dev-python/gst-python:0.10[${PYTHON_USEDEP}] )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.2
+ >=dev-util/gtk-doc-am-1.3
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.17 )
+"
+
+# Does not provide any unittest
+RESTRICT="test"
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed -e 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in \
+ || die
+ fi
+
+ # don't waste time building examples
+ sed -e 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in \
+ || die
+
+ use vala && vala_src_prepare
+}
+
+multilib_src_configure() {
+ if use python ; then
+ python_setup
+ fi
+
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behing that switch
+ gstreamer_multilib_src_configure \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable vala) \
+ PYTHON=$(multilib_native_usex python "${PYTHON}" false) \
+ PYGOBJECT_REQ=${PYGOBJECT_REQ}
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild
new file mode 100644
index 000000000000..e5a82326cf24
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="http://people.freedesktop.org/~wtay/"
+
+LICENSE="LGPL-2"
+KEYWORDS="amd64 x86"
+IUSE="examples +introspection static-libs test"
+
+# FIXME: check should depend on USE=test but check is losy
+# configure says good and bad are required by macros forces them to be optional
+# they are only used in unittests anyway.
+RDEPEND="
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-1.4:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-1.4:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.2
+ >=dev-util/gtk-doc-am-1.12
+ virtual/pkgconfig
+ test? (
+ >=media-libs/gst-plugins-bad-1.4:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-1.4:${SLOT}[${MULTILIB_USEDEP}]
+ )
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+src_prepare() {
+ # don't waste time building examples
+ sed -e '/SUBDIRS.*=/,/^$/ { s/examples// };' \
+ -i Makefile.am Makefile.in \
+ || die
+}
+
+multilib_src_configure() {
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behind that switch
+ # libcgroup is automagic and only used in examples
+ gstreamer_multilib_src_configure \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ LIBCGROUP_LIBS= \
+ LIBCGROUP_FLAGS=
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}
diff --git a/media-libs/gst-rtsp-server/metadata.xml b/media-libs/gst-rtsp-server/metadata.xml
new file mode 100644
index 000000000000..9e260ceca3e3
--- /dev/null
+++ b/media-libs/gst-rtsp-server/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+</pkgmetadata>