summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-03-17 21:53:34 +0300
committerSam James <sam@gentoo.org>2022-03-18 00:31:41 +0000
commit3bbfabcbf72ad21914c56e510158935e3bafbe89 (patch)
treeb10a0a20b4e664ca657361fab08283bc6926fc77 /media-libs/gstreamer
parentmedia-sound/pulseaudio: Add USE=aptx dependency on gst-plugins-openaptx (diff)
downloadgentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.gz
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.bz2
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.zip
media-libs/gstreamer: Version bump, 1.18.6
Bug: https://bugs.gentoo.org/835368 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24625 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.18.6.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index c0807f2bd137..f86931733814 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1,3 +1,4 @@
DIST gstreamer-1.16.3.tar.xz 3338692 BLAKE2B 79eb08bc446073fadf881adea0f60a2caf6384836df975f80ce0e57db6469e6a016cab38413d3de00d11b491a0281f95dcbcd1f782b31f2d1a07b866c1ed7dd5 SHA512 4a879e71f65c89609c2e106dc79222853e6f37830638d5b9624c436fc9d8974cc6474d399eff02cdc13ff7189fcd13e9450450d36c3a6092aa53cb97056f5854
DIST gstreamer-1.18.4.tar.xz 2703948 BLAKE2B b11be1309e7a6ad0aff24aa99b10b1c16df4b1720b821421a72ec9d9b20087488901bb4667e797d32ef616f909c3aefd301fac6be9c4c4120ec9e4af3acc7b48 SHA512 5312c621fc354b35cc81f53b4ec65c661ad2c22acef2640bc27860234243d06e00e3aaf41c93d379d8424c0ecdf2ae06096dec0d0313215426348ffa0afb3c4a
+DIST gstreamer-1.18.6.tar.xz 2713892 BLAKE2B 93642e33f0812cae60318ac821fcda450b15894e44d17e1e4dae3a9d84f20e86bbb418bf924fdf2cc52e4bcbbea8cf8fac530157bc48e43fb86819c587ad1aab SHA512 9598da87a6e87ddd134542dd72e110ce53bb673a8f29484d85ce4daff2a19e1fb5c392ddad460d0bb9138a51ae65f06ba2e7251636bbee272070feea428facac
DIST gstreamer-1.20.1.tar.xz 2674128 BLAKE2B c05c29ac53df2ed5d60c3f2e9dcbc130e4733bc19fbb23b31285190cd68e5abd2a9209e87b4cd481719944b4fcdf6b0e1dbc1a7ba93cfa96fd305e698f971b3a SHA512 d6f67cce81ba15fba3fcf70850e3c84b25e8da3e53fd56e6f2c87c7ee1701071ea44deb754a0ea371b3cb17877f26aab94d9eccb6729cbb370d6d6d5c324aa1a
diff --git a/media-libs/gstreamer/gstreamer-1.18.6.ebuild b/media-libs/gstreamer/gstreamer-1.18.6.ebuild
new file mode 100644
index 000000000000..865d7a4a1928
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.18.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection +orc unwind"
+
+RDEPEND="
+ caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ unwind? (
+ >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ )
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/bison
+ sys-devel/flex
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dcheck=enabled
+ $(meson_feature unwind libunwind)
+ $(meson_feature unwind libdw)
+ )
+
+ if use caps ; then
+ emesonargs+=( -Dptp-helper-permissions=capabilities )
+ else
+ emesonargs+=(
+ -Dptp-helper-permissions=setuid-root
+ -Dptp-helper-setuid-user=nobody
+ -Dptp-helper-setuid-group=nobody
+ )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ DESTDIR="${D}" eninja install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/bin/gst-launch-${SLOT}"
+}