summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-05-10 18:38:45 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-05-10 18:39:03 -0400
commitf59f39fb234fe5ce1c2a4c1c63be575fa494302c (patch)
treeb821640b112b55d09e624364906dbe43ccbe3034 /media-libs/gstreamer
parentmedia-gfx/eom: Revbump to 1.10.5-r2, resolves #574376 (diff)
downloadgentoo-f59f39fb234fe5ce1c2a4c1c63be575fa494302c.tar.gz
gentoo-f59f39fb234fe5ce1c2a4c1c63be575fa494302c.tar.bz2
gentoo-f59f39fb234fe5ce1c2a4c1c63be575fa494302c.zip
media-libs/gstreamer: fix bug #577312
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch29
-rw-r--r--media-libs/gstreamer/gstreamer-1.6.3.ebuild4
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch b/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch
new file mode 100644
index 000000000000..e237f9b50e75
--- /dev/null
+++ b/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch
@@ -0,0 +1,29 @@
+From c9da8b0e7f53005ab125e48165dae39fbfee2352 Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Sun, 13 Mar 2016 11:05:29 -0400
+Subject: libcompat.h: strsignal() should be not be decleared const
+
+POSIX standards requires strsignal() to return a pointer to a char,
+not a const pointer to a char. [1] On uClibc, and possibly other
+libc's, that do not HAVE_DECL_STRSIGNAL, libcompat.h declares
+const char *strsignal (int sig) which causes a type error.
+
+[1] man 3 strsignal
+
+https://bugzilla.gnome.org/show_bug.cgi?id=763567
+
+diff --git a/libs/gst/check/libcheck/strsignal.c b/libs/gst/check/libcheck/strsignal.c
+index b79409b..57e71cd 100644
+--- a/libs/gst/check/libcheck/strsignal.c
++++ b/libs/gst/check/libcheck/strsignal.c
+@@ -1,6 +1,6 @@
+ #include "libcompat.h"
+
+-const char *
++char *
+ strsignal (int sig)
+ {
+ static char signame[40];
+--
+cgit v0.10.2
+
diff --git a/media-libs/gstreamer/gstreamer-1.6.3.ebuild b/media-libs/gstreamer/gstreamer-1.6.3.ebuild
index 3b778476c233..63ff72f9f12c 100644
--- a/media-libs/gstreamer/gstreamer-1.6.3.ebuild
+++ b/media-libs/gstreamer/gstreamer-1.6.3.ebuild
@@ -30,6 +30,10 @@ DEPEND="${RDEPEND}
"
# gtk-doc-am to install API docs
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-strsignal.patch #577312
+}
+
src_configure() {
if [[ ${CHOST} == *-interix* ]] ; then
export ac_cv_lib_dl_dladdr=no