summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-23 10:17:40 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-23 10:36:00 -0700
commit530376277028a11f75a8ace052f83707270a1e9f (patch)
tree723e7d535321a740ca360328e2d5a850914ced67 /media-libs/gupnp-dlna
parentnet-libs/gupnp-igd: Version bump to 1.2.0 (diff)
downloadgentoo-530376277028a11f75a8ace052f83707270a1e9f.tar.gz
gentoo-530376277028a11f75a8ace052f83707270a1e9f.tar.bz2
gentoo-530376277028a11f75a8ace052f83707270a1e9f.zip
media-libs/gupnp-dlna: Version bump to 0.11.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/gupnp-dlna')
-rw-r--r--media-libs/gupnp-dlna/Manifest1
-rw-r--r--media-libs/gupnp-dlna/gupnp-dlna-0.11.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/gupnp-dlna/Manifest b/media-libs/gupnp-dlna/Manifest
index 125e002e7f5d..6a20ce191733 100644
--- a/media-libs/gupnp-dlna/Manifest
+++ b/media-libs/gupnp-dlna/Manifest
@@ -1 +1,2 @@
DIST gupnp-dlna-0.10.5.tar.xz 329468 BLAKE2B 045c890bc05e7a8e8321c46b333b27ec112b470f484961b24dad5652c0d065db52187c4ac19ed392319e12d2cf7b835b43304edf1307ffc3bb5f2c5c7baded4c SHA512 060e997dc85d840722bc31c8eb2c7f986151220ac6f3de9e073f4dd62fdd57ffa049b628080832d6b96c1988f49eacc29d539f738ed61797019264f68ebf7680
+DIST gupnp-dlna-0.11.0.tar.xz 87920 BLAKE2B 8391503c66da267d936563b1b39b1f390bdeb2d4511a900fb99faf968307026e857b66d2f43dd14309e9e4e9790801538947f6c8506391c0da39db6a7b854a6b SHA512 26aad6eb3f7705fa586552a1e4d6931b3ff28b6dbcfd7a626dea297ffd90e67f02957b68e0bb6c80e4fd445dbba1bd47dc47bcf8ac389ff2bb0622cd9ca7f3d1
diff --git a/media-libs/gupnp-dlna/gupnp-dlna-0.11.0.ebuild b/media-libs/gupnp-dlna/gupnp-dlna-0.11.0.ebuild
new file mode 100644
index 000000000000..53b0232ab7d5
--- /dev/null
+++ b/media-libs/gupnp-dlna/gupnp-dlna-0.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson vala
+
+DESCRIPTION="Library providing DLNA-related functionality for MediaServers"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gupnp-dlna"
+
+LICENSE="LGPL-2"
+SLOT="2.0/4" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libxml2-2.5:2
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgstreamer_backend=enabled
+ -Ddefault_backend=gstreamer
+ $(meson_use introspection)
+ $(meson_use introspection vapi)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}