summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-06-24 07:46:28 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2021-06-24 07:46:28 +0200
commit108c5996b25c0f0e7b78d7784343dd2bb1d4515c (patch)
treedf141262959e75da36d8d7288d5d8dab765912eb /media-libs/hamlib
parentmedia-radio/grig: Prepare for coming media-libs/hamlib42 (diff)
downloadgentoo-108c5996b25c0f0e7b78d7784343dd2bb1d4515c.tar.gz
gentoo-108c5996b25c0f0e7b78d7784343dd2bb1d4515c.tar.bz2
gentoo-108c5996b25c0f0e7b78d7784343dd2bb1d4515c.zip
media-libs/hamlib: Version bump
Closes: https://bugs.gentoo.org/796866 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-4.2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index b6f546e6b23d..5c3d50cf665e 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1 +1,2 @@
DIST hamlib-4.1.tar.gz 2260629 BLAKE2B e53249f476005f3ec8afcbba6d875d913cdc45eb741fdb8b8718c1c5bda9cf8d50087165b72055600bc9ff364117f7d72235a3d68a9fb0882a77a6fdbf366605 SHA512 a5fca5dc89a7408628bc77fe22c6d8c77474b3dabee7b2b6d0b280becb6cb63f5619e4a620ad11aeb81b8412145b0f8cb0291a2d4cd3751c643cb1709b2dfa78
+DIST hamlib-4.2.tar.gz 2311775 BLAKE2B 4fe8d3e6d489369aede1a4cd59f01be44a7787ca71c21c5b92d436666c67de68013f488834d0f57238e6a947c24cd5b4c6c667397dec30392f1cccd695df252e SHA512 08ccf4e592fbae938ae1aaa5afede7e2e6ec7d23b449a65b00e093502f4aeb36930624f055d9802349f77df9dd2b7b983aa44d83f8c62a6de5789e7df627f804
diff --git a/media-libs/hamlib/hamlib-4.2.ebuild b/media-libs/hamlib/hamlib-4.2.ebuild
new file mode 100644
index 000000000000..a1babce2a0e4
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+MY_P=${P/_rc2/~rc2}
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="https://www.hamlib.org"
+SRC_URI="mirror://sourceforge/hamlib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0/4.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+}