summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-12-29 18:54:50 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2020-12-29 18:55:13 +0100
commit22b1c29102e7bd9b6d4902c9afec9dd47513f02c (patch)
tree5a2553597a9822c3a751813ef4c537b76161a81b /media-libs/hamlib
parentnet-proxy/tinyproxy: Stabilize 1.11.0_rc1 amd64, #762289 (diff)
downloadgentoo-22b1c29102e7bd9b6d4902c9afec9dd47513f02c.tar.gz
gentoo-22b1c29102e7bd9b6d4902c9afec9dd47513f02c.tar.bz2
gentoo-22b1c29102e7bd9b6d4902c9afec9dd47513f02c.zip
media-libs/hamlib: Major version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-4.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index 04a2aeab2765..6c406fe1edd8 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1,2 +1,3 @@
DIST hamlib-3.3.tar.gz 2192119 BLAKE2B edefd8b8c75876c07fa498c98f7d6760985fdecc477bf6711e948071e45964bf7fdf6705b3172e56951366a7dfb0288e025eab66d3b6436d158649ae53ac39bd SHA512 4cf6c94d0238c8a13aed09413b3f4a027c8ded07f8840cdb2b9d38b39b6395a4a88a8105257015345f6de0658ab8c60292d11a9de3e16a493e153637af630a80
+DIST hamlib-4.0.tar.gz 2242857 BLAKE2B 458a5cadc36f8f434fefc73b6230b08c858a741a685805e8d8ab1e2bd74aef9667d6b3d006aa493516830a6fc8af19e77b4d92736198bb920797aecfac605f41 SHA512 6c097f503d1050dca4e5ab9091cd9885f8db8b0e4b2fb26af570f1871f2da713ac3fe10e3629d20ebfc2927768555ad277e68cc38821f4a905900b8d3a5ba8c9
DIST hamlib-4.0~rc2.tar.gz 2188867 BLAKE2B 02df21910266e47c99e3cd72fc815ed75b9b5f50b29b9a94aa6fc5ddac73b1a09d16caa0d5e4be71bfe44e1940b853a0a8e1303f23fbacf003da18eed198531c SHA512 6d192bbb1c98e76fdfd1dd6bde1d0fd8b668243332827ae609e7bb4a93a3fed9fda0b12363638f5e9df65d65fd2305dfd493bd37a99aca2f2bd5b0861e948d5b
diff --git a/media-libs/hamlib/hamlib-4.0.ebuild b/media-libs/hamlib/hamlib-4.0.ebuild
new file mode 100644
index 000000000000..d52c7828e6ad
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="https://www.hamlib.org"
+SRC_URI="https://www.github.com/${PN}/${PN}/releases/download/${PVR}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+}