summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2016-01-07 17:35:40 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2016-01-07 17:37:30 +0100
commitdcd3985b87598a563f1f6ab3411fcc8181dc53e2 (patch)
treefb2dd901d00871d6b2becd12a34a930bb3dad5f4 /media-libs/hamlib
parentdev-lang/swi-prolog: bump 7.3 development version (diff)
downloadgentoo-dcd3985b87598a563f1f6ab3411fcc8181dc53e2.tar.gz
gentoo-dcd3985b87598a563f1f6ab3411fcc8181dc53e2.tar.bz2
gentoo-dcd3985b87598a563f1f6ab3411fcc8181dc53e2.zip
media-libs/hamlib: Bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-3.0.1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index bf3a3c315513..dcc0f3feaeeb 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1,2 +1,3 @@
DIST hamlib-1.2.15.3.tar.gz 1675879 SHA256 a2ca4549e4fd99d6e5600e354ebcb57502611aa63c6921c1b8a825289833f75e SHA512 88f9cb8d82d813ac02944def0adf6eada0e4ed1407f60e344d51172462d51ab0c3ddd9cbf9ef8cbd61efba6c4158a77acb7c23b886e174c9a082bf1dd11f5baa WHIRLPOOL 33f8e114d05c778e30c1b634e2494cd3f9d89213ccc58b34b4d195bb4f1c803c5451f54c8e232bf276a1daebe6c0a01bae73a51fa90538fe537d3b5bf4ce91de
+DIST hamlib-3.0.1.tar.gz 2074254 SHA256 3fec97ea326d02aa8f35834c4af34194a3f544e6212f391397d788c566b44e32 SHA512 c71d76343092da03dd3bd8470494fe9bd2789597ab3c83a5c98e007c94016c59de21cdbfb461fa6093e27ca8f300cfed65b4ba7e579b3070c6ed0bf6a4de38b2 WHIRLPOOL 95b2ac3d692461085009dc3c45a699c106e0a49e4367d138d18238b32444ffc0a160281c146eb53721ff2e4f12daad3262cf4c772bab318a3b20328d84732adb
DIST hamlib-3.0.tar.gz 2074188 SHA256 bc16546161a47e21a44a710a40aeb0bce478f112bffcc4f253eb27e150f1c21e SHA512 16ac66ab91d44c364054aa6ba8292a6538886744d83a83eb0887f55407f836e1d4a402cc7a41576594bea8100c2eefa26bae212f767a68b2a4db7a709166cbd2 WHIRLPOOL 31f96037260160e83f376e87f35669cac73772b73d4b50bf78b32893de17d36e02d41d71ab393ac6fa27efbb387a88d71bdc8cb4a7c02c7251b141afea6d82a9
diff --git a/media-libs/hamlib/hamlib-3.0.1.ebuild b/media-libs/hamlib/hamlib-3.0.1.ebuild
new file mode 100644
index 000000000000..cf7445e88a8d
--- /dev/null
+++ b/media-libs/hamlib/hamlib-3.0.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils eutils multilib python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)/hamlib
+ --disable-static
+ --with-xml-support
+ $(use_with perl perl-binding)
+ $(use_with python python-binding)
+ $(use_with tcl tcl-binding)
+ --disable-silent-rules
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
+ autotools-utils_src_install
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib || die "doenvd failed"
+}