summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-09 15:49:20 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-09 15:49:43 +0000
commit5e2c1c13fa388533d075554da87d3641019aa739 (patch)
tree838778ba8bb7447d107acfd1a06588aae4164652 /media-libs/harfbuzz
parentdev-lang/nim: drop old (diff)
downloadgentoo-5e2c1c13fa388533d075554da87d3641019aa739.tar.gz
gentoo-5e2c1c13fa388533d075554da87d3641019aa739.tar.bz2
gentoo-5e2c1c13fa388533d075554da87d3641019aa739.zip
media-libs/harfbuzz: fux current stable against gcc-9
Fix build failure on gcc-9. It's a slightly less invasive version of upstream's commit 2dce85ed06a8cc7ca ("[icu] Remove HB_ICU_STMT (#1993)") Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/files/harfbuzz-2.6.1-gcc-9.patch14
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.6.1.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/files/harfbuzz-2.6.1-gcc-9.patch b/media-libs/harfbuzz/files/harfbuzz-2.6.1-gcc-9.patch
new file mode 100644
index 000000000000..c16fedd6d9d6
--- /dev/null
+++ b/media-libs/harfbuzz/files/harfbuzz-2.6.1-gcc-9.patch
@@ -0,0 +1,14 @@
+Fix build failure on gcc-9. It's a slightly less invasive
+version of upstream's commit 2dce85ed06a8cc7ca
+("[icu] Remove HB_ICU_STMT (#1993)")
+--- a/src/hb-icu.cc
++++ b/src/hb-icu.cc
+@@ -53,7 +53,7 @@
+
+ /* ICU doesn't do-while(0) around their statements. Ugh!
+ * https://unicode-org.atlassian.net/browse/CLDR-13027 */
+-#define HB_ICU_STMT(S) do { S } while (0)
++#define HB_ICU_STMT(S) do { S; } while (0)
+
+ hb_script_t
+ hb_icu_script_to_script (UScriptCode script)
diff --git a/media-libs/harfbuzz/harfbuzz-2.6.1.ebuild b/media-libs/harfbuzz/harfbuzz-2.6.1.ebuild
index d8eb3a9c8943..87e7095493c9 100644
--- a/media-libs/harfbuzz/harfbuzz-2.6.1.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-2.6.1.ebuild
@@ -48,6 +48,10 @@ if [[ ${PV} = 9999 ]] ; then
"
fi
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-9.patch
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
if ! use debug ; then