summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-27 12:15:25 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-27 12:16:38 +0100
commit50362025a8e77346baa5f1240924971eab1dcfe2 (patch)
treee551d3920dcd010ca38979a8a555e1671c4dc0af /media-libs/jasper
parentapp-text/catdoc: cleanup vulnerable wrt sec bug #571820 (diff)
downloadgentoo-50362025a8e77346baa5f1240924971eab1dcfe2.tar.gz
gentoo-50362025a8e77346baa5f1240924971eab1dcfe2.tar.bz2
gentoo-50362025a8e77346baa5f1240924971eab1dcfe2.zip
media-libs/jasper: use set() instead of option() in CMakeLists.txt
* option() should only be used for boolean arguments https://cmake.org/cmake/help/latest/command/option.html?highlight=option Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/jasper')
-rw-r--r--media-libs/jasper/files/jasper-2.0.0-fix-build-system.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/media-libs/jasper/files/jasper-2.0.0-fix-build-system.patch b/media-libs/jasper/files/jasper-2.0.0-fix-build-system.patch
index bae54760f470..f95023be106d 100644
--- a/media-libs/jasper/files/jasper-2.0.0-fix-build-system.patch
+++ b/media-libs/jasper/files/jasper-2.0.0-fix-build-system.patch
@@ -8,7 +8,7 @@
option(JAS_ENABLE_OPENGL "Enable use of OpenGL Library" true)
option(JAS_ENABLE_STRICT "Enable pedantic error checking" false)
option(JAS_ENABLE_SHARED "Enable building of shared library" true)
-+option(CMAKE_INSTALL_LIBDIR "Path to install libraries into" lib)
++set(CMAKE_INSTALL_LIBDIR lib CACHE PATH "Path to install libraries into")
if (APPLE AND ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
set(MACOSX true)