summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-15 10:56:32 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-15 10:57:15 -0400
commit8733e400fb540e3161ec866ee4092ccc5a8fb713 (patch)
tree7beda9c19eb3323bbf14544aab86d6769e516253 /media-libs/jasper
parentmedia-libs/jasper: stable ppc/ppc64 per slyfox's comment on bug (diff)
downloadgentoo-8733e400fb540e3161ec866ee4092ccc5a8fb713.tar.gz
gentoo-8733e400fb540e3161ec866ee4092ccc5a8fb713.tar.bz2
gentoo-8733e400fb540e3161ec866ee4092ccc5a8fb713.zip
media-libs/jasper: drop vulnerable
Bug: https://bugs.gentoo.org/614030 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'media-libs/jasper')
-rw-r--r--media-libs/jasper/Manifest1
-rw-r--r--media-libs/jasper/jasper-2.0.12.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/media-libs/jasper/Manifest b/media-libs/jasper/Manifest
index 012a855f8d31..a36492e7b897 100644
--- a/media-libs/jasper/Manifest
+++ b/media-libs/jasper/Manifest
@@ -1,2 +1 @@
-DIST jasper-2.0.12.tar.gz 1311323 BLAKE2B bc9922bfc4765ea4630f9a504c9e5a1c0992f78c2ef68cd077ba0c8a36332debd5db9fc5c639accc7eaa0eda64e478c1e615da9f2eaf363446635dd94a253fa0 SHA512 a308983511119d85e6580772f5164c188e2e170500fa4b98c8831aa63aa87cb661b88952b278e390497571f9ebf9286855a8aa946037692309ba5f41cffe265a
DIST jasper-2.0.14.tar.gz 1311825 BLAKE2B 0cd2feb5a73aaa2da6f1d105fefe98f57c6a5ecf92f6449891f49eca0b5926bc683a03bf933b920cad95883134cf292405f244f10b3bbe7867a41f2dde80337e SHA512 6b270cb1eb55f777f30016f3258e5e2297627e7d086334814c308464f5a4552c23241b0fdbc81ea715a6f4746294657f96c1cb6ceb320629ce57db7e81d84940
diff --git a/media-libs/jasper/jasper-2.0.12.ebuild b/media-libs/jasper/jasper-2.0.12.ebuild
deleted file mode 100644
index e6fab3f30a0f..000000000000
--- a/media-libs/jasper/jasper-2.0.12.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
-HOMEPAGE="https://www.ece.uvic.ca/~mdadams/jasper/"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-
-# We limit memory usage to 128 MiB by default, specified in bytes
-: ${JASPER_MEM_LIMIT:=134217728}
-
-LICENSE="JasPer2.0"
-SLOT="0/4"
-IUSE="doc jpeg opengl"
-
-RDEPEND="
- jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
- opengl? (
- >=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
- >=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
- virtual/glu[${MULTILIB_USEDEP}]
- x11-libs/libXi[${MULTILIB_USEDEP}]
- x11-libs/libXmu[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DALLOW_IN_SOURCE_BUILD=OFF
- -DBASH_PROGRAM="${EPREFIX}"/bin/bash
- -DJAS_ENABLE_ASAN=OFF
- -DJAS_ENABLE_LSAN=OFF
- -DJAS_ENABLE_MSAN=OFF
- -DJAS_ENABLE_SHARED=ON
- -DJAS_ENABLE_STRICT=ON
- -DJAS_ENABLE_USAN=OFF
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
-
- # JPEG
- -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
- -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)
-
- # OpenGL
- -DJAS_ENABLE_OPENGL=$(usex opengl)
- -DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)
-
- # Doxygen
- -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
- )
- cmake-utils_src_configure
-}