summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-19 18:50:02 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-19 18:50:30 +0100
commiteb36e07061ee2a0420ee93b9df34445eda0ad7f0 (patch)
tree541671d0cc0e2539a9b8a592cc2fd78ac7972094 /media-libs/jbig2dec/jbig2dec-0.13-r1.ebuild
parentdev-python/pyopenssl: use pytest collector (diff)
downloadgentoo-eb36e07061ee2a0420ee93b9df34445eda0ad7f0.tar.gz
gentoo-eb36e07061ee2a0420ee93b9df34445eda0ad7f0.tar.bz2
gentoo-eb36e07061ee2a0420ee93b9df34445eda0ad7f0.zip
media-libs/jbig2dec: Add patch for CVE-2016-9601, bug 607188
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/jbig2dec/jbig2dec-0.13-r1.ebuild')
-rw-r--r--media-libs/jbig2dec/jbig2dec-0.13-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/jbig2dec/jbig2dec-0.13-r1.ebuild b/media-libs/jbig2dec/jbig2dec-0.13-r1.ebuild
new file mode 100644
index 000000000000..55a50a74c4de
--- /dev/null
+++ b/media-libs/jbig2dec/jbig2dec-0.13-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A decoder implementation of the JBIG2 image compression format"
+HOMEPAGE="http://ghostscript.com/jbig2dec.html"
+SRC_URI="http://downloads.ghostscript.com/public/${PN}/${P}.tar.gz
+ test? ( http://jbig2dec.sourceforge.net/ubc/jb2streams.zip )"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="png static-libs test"
+
+RDEPEND="png? ( media-libs/libpng:0= )"
+DEPEND="${RDEPEND}
+ test? ( app-arch/unzip )"
+
+RESTRICT="test"
+# bug 324275
+
+DOCS="CHANGES README"
+
+PATCHES=(
+ "${FILESDIR}/${P}-CVE-2016-9601.patch"
+)
+
+src_prepare() {
+ default
+
+ if use test; then
+ mkdir "${WORKDIR}/ubc" || die
+ mv -v "${WORKDIR}"/*.jb2 "${WORKDIR}/ubc/" || die
+ mv -v "${WORKDIR}"/*.bmp "${WORKDIR}/ubc/" || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with png libpng)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm {} + || die
+}