summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2020-09-08 18:45:29 -0300
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:56:51 +0100
commit4b7f80d7076db0877dc50853adb4ef7db68238d4 (patch)
tree40f00f540ba105e78bcaa9c131c4d834fd1c3b3d /media-libs/kimageannotator
parentmedia-libs/kcolorpicker: New package (diff)
downloadgentoo-4b7f80d7076db0877dc50853adb4ef7db68238d4.tar.gz
gentoo-4b7f80d7076db0877dc50853adb4ef7db68238d4.tar.bz2
gentoo-4b7f80d7076db0877dc50853adb4ef7db68238d4.zip
media-libs/kimageannotator: New package
This package (and media-libs/kcolorpicker) will soon be dependencies of kde-apps/spectacle to add annotation capabilities. I have been maintaining both in the GURU overlay since about May 2020. Suggested-by: Andreas Sturmlechner <asturm@gentoo.org> Bug: https://bugs.gentoo.org/723758 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/kimageannotator')
-rw-r--r--media-libs/kimageannotator/Manifest1
-rw-r--r--media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch25
-rw-r--r--media-libs/kimageannotator/kimageannotator-0.4.0.ebuild51
-rw-r--r--media-libs/kimageannotator/metadata.xml12
4 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/kimageannotator/Manifest b/media-libs/kimageannotator/Manifest
new file mode 100644
index 000000000000..5979ed0a2318
--- /dev/null
+++ b/media-libs/kimageannotator/Manifest
@@ -0,0 +1 @@
+DIST kImageAnnotator-0.4.0.tar.gz 164030 BLAKE2B 09ec5eb18d212739c21b30809808cdd453321bf785fd79d21ae3ad5259edfb1dcddbac4de3fc68131627f0252c67f45f22d8572d91bb8c182d68e0d3140bcad5 SHA512 4fb76ff889ad4619080246f91e92fe9683056766b96faa071e0f73efd7c3647f90716fcf94b283461cd0152bdaa647002d26ffc7bf2cd1756ecdf3111005085a
diff --git a/media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch b/media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch
new file mode 100644
index 000000000000..7944118641c3
--- /dev/null
+++ b/media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch
@@ -0,0 +1,25 @@
+From 25f13f3058c79e3f4a2b1cd257b213f102931cc3 Mon Sep 17 00:00:00 2001
+From: Dave Flogeras <dflogeras2@gmail.com>
+Date: Wed, 6 Jan 2021 20:07:20 -0400
+Subject: [PATCH] Make test static library explicitly link against kColorPicker
+ and X11.
+
+This was broken when those libraries were made part of a PRIVATE
+interface by bbc2b6595 and af2ff6167.
+---
+ tests/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index b1ecc8a..9918010 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -56,7 +56,7 @@ set(TESTUTILS_SRC
+
+ add_library(KIMAGEANNOTATOR_STATIC STATIC ${KIMAGEANNOTATOR_SRCS})
+
+-target_link_libraries(KIMAGEANNOTATOR_STATIC Qt5::Widgets Qt5::Svg kImageAnnotator)
++target_link_libraries(KIMAGEANNOTATOR_STATIC Qt5::Widgets Qt5::Svg kImageAnnotator kColorPicker::kColorPicker X11)
+
+ target_compile_definitions(KIMAGEANNOTATOR_STATIC PRIVATE KIMAGEANNOTATOR_LANG_INSTALL_DIR="${KIMAGEANNOTATOR_LANG_INSTALL_DIR}")
+
diff --git a/media-libs/kimageannotator/kimageannotator-0.4.0.ebuild b/media-libs/kimageannotator/kimageannotator-0.4.0.ebuild
new file mode 100644
index 000000000000..417b4bc23c2d
--- /dev/null
+++ b/media-libs/kimageannotator/kimageannotator-0.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kImageAnnotator
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for annotating images"
+HOMEPAGE="https://github.com/ksnip/kImageAnnotator"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png]
+ >=media-libs/kcolorpicker-0.1.4
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+PATCHES=(
+ # https://github.com/ksnip/kImageAnnotator/pull/195
+ "${FILESDIR}/${P}-fix-static-test-library-PR195.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
diff --git a/media-libs/kimageannotator/metadata.xml b/media-libs/kimageannotator/metadata.xml
new file mode 100644
index 000000000000..325675c5861e
--- /dev/null
+++ b/media-libs/kimageannotator/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dflogeras2@gmail.com</email>
+ <name>David Flogeras</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>