summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-07-09 11:19:26 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-07-09 11:20:07 +0200
commit6be819b924c7df9591ab3a3025d5f237bbcae1de (patch)
tree428e57c021497611dbfbe7f7e01251a224397840 /media-libs/ladspa-cmt/files/ladspa-cmt-1.17-makefile.patch
parentmedia-libs/ladspa-sdk: bump to 1.15 (diff)
downloadgentoo-6be819b924c7df9591ab3a3025d5f237bbcae1de.tar.gz
gentoo-6be819b924c7df9591ab3a3025d5f237bbcae1de.tar.bz2
gentoo-6be819b924c7df9591ab3a3025d5f237bbcae1de.zip
media-libs/ladspa-cmt: bump to 1.17
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/ladspa-cmt/files/ladspa-cmt-1.17-makefile.patch')
-rw-r--r--media-libs/ladspa-cmt/files/ladspa-cmt-1.17-makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/ladspa-cmt/files/ladspa-cmt-1.17-makefile.patch b/media-libs/ladspa-cmt/files/ladspa-cmt-1.17-makefile.patch
new file mode 100644
index 000000000000..866cbfdbfc65
--- /dev/null
+++ b/media-libs/ladspa-cmt/files/ladspa-cmt-1.17-makefile.patch
@@ -0,0 +1,27 @@
+diff --git a/src/Makefile b/src/Makefile
+index 159dd46..3b8aeeb 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -11,7 +11,7 @@ INSTALL_PLUGINS_DIR = /usr/lib/ladspa/
+ # GENERAL
+ #
+
+-CFLAGS = $(INCLUDES) -Wall -Werror -O2 -fPIC
++CFLAGS = $(INCLUDES) -Wall -Werror -fPIC
+ CXXFLAGS = $(CFLAGS)
+ PLUGIN_LIB = ../plugins/cmt.so
+
+@@ -66,11 +66,11 @@ plugin: $(PLUGIN_LIB)
+ targets: $(PLUGIN_LIB)
+
+ $(PLUGIN_LIB): $(PLUGIN_OBJECTS) gcc_exports.map
+- $(CXX) -shared \
++ $(CXX) $(LDFLAGS) \
++ -shared \
+ $(CFLAGS) \
+ -fvisibility=hidden \
+ -fvisibility-inlines-hidden \
+- -s \
+ -Wl,--version-script=gcc_exports.map \
+ -o $(PLUGIN_LIB) \
+ $(PLUGIN_OBJECTS)