summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-05-19 23:14:37 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-05-19 23:18:30 +0300
commita10af478c0bf6cc51d83b7459371c5623186e23c (patch)
tree36d7f9cd459ebb0d4117a29ca71ec4d100cb5c26 /media-libs/lasi
parentdev-ada/xmlada: fix VariableScope (diff)
downloadgentoo-a10af478c0bf6cc51d83b7459371c5623186e23c.tar.gz
gentoo-a10af478c0bf6cc51d83b7459371c5623186e23c.tar.bz2
gentoo-a10af478c0bf6cc51d83b7459371c5623186e23c.zip
media-libs/lasi: fix build with gcc-11
This package requires dynamic exceptions, so stay on gnu++14 to avoid major code rewrite. Closes: https://bugs.gentoo.org/788766 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'media-libs/lasi')
-rw-r--r--media-libs/lasi/lasi-1.1.3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-libs/lasi/lasi-1.1.3.ebuild b/media-libs/lasi/lasi-1.1.3.ebuild
index c2f08f49bcb8..df41f56e078e 100644
--- a/media-libs/lasi/lasi-1.1.3.ebuild
+++ b/media-libs/lasi/lasi-1.1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
MY_PN=libLASi
MY_P=${MY_PN}-${PV}
@@ -49,6 +49,8 @@ src_prepare() {
}
src_configure() {
+ # 788766
+ append-cxxflags -std=gnu++14
# doesn't like CMAKE_BUILD_TYPE = Gentoo
CMAKE_BUILD_TYPE=None
local mycmakeargs=(