summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-03-30 10:11:28 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-03-30 10:11:28 +0000
commit8baeb6bfce5f9af05903bf8d0a417b4db0ae81ca (patch)
tree5ce4fc4fa6be6b8305dd5ced6c3a3b3dd36dc5fb /media-libs/leptonica/leptonica-1.78.0.ebuild
parentapp-office/libreoffice-l10n: Drop 6.1.2.1 (diff)
downloadgentoo-8baeb6bfce5f9af05903bf8d0a417b4db0ae81ca.tar.gz
gentoo-8baeb6bfce5f9af05903bf8d0a417b4db0ae81ca.tar.bz2
gentoo-8baeb6bfce5f9af05903bf8d0a417b4db0ae81ca.zip
media-libs/leptonica: Version bump to 1.78.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/leptonica/leptonica-1.78.0.ebuild')
-rw-r--r--media-libs/leptonica/leptonica-1.78.0.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/leptonica/leptonica-1.78.0.ebuild b/media-libs/leptonica/leptonica-1.78.0.ebuild
new file mode 100644
index 000000000000..1e8f7a678d8b
--- /dev/null
+++ b/media-libs/leptonica/leptonica-1.78.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for image processing and analysis"
+HOMEPAGE="http://www.leptonica.org/"
+SRC_URI="https://github.com/DanBloomberg/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="gif jpeg jpeg2k png static-libs test tiff utils webp zlib"
+
+# N.B. Tests need some features enabled:
+REQUIRED_USE="test? ( jpeg png tiff zlib )"
+
+RDEPEND="gif? ( >=media-libs/giflib-5.1.3:=[${MULTILIB_USEDEP}] )
+ jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
+ jpeg2k? ( media-libs/openjpeg:2=[${MULTILIB_USEDEP}] )
+ png? ( media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff:0=[${MULTILIB_USEDEP}] )
+ webp? ( media-libs/libwebp:=[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib:=[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ test? ( media-libs/tiff:0[zlib] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gnuplot.patch
+)
+
+ECONF_SOURCE="${S}"
+DOCS=( README version-notes )
+
+src_prepare() {
+ default
+
+ # unhtmlize docs
+ local X
+ for X in ${DOCS[@]}; do
+ awk '/<\/pre>/{s--} {if (s) print $0} /<pre>/{s++}' \
+ "${X}.html" > "${X}" || die 'awk failed'
+ rm -f -- "${X}.html"
+ done
+}
+
+multilib_src_configure() {
+ econf \
+ --enable-shared \
+ $(use_with gif giflib) \
+ $(use_with jpeg) \
+ $(use_with jpeg2k libopenjpeg) \
+ $(use_with png libpng) \
+ $(use_with tiff libtiff) \
+ $(use_with webp libwebp) \
+ $(use_with zlib) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable utils programs)
+}
+
+multilib_src_test() {
+ default
+
+ # ${TMPDIR} is not respected. It used to be but it lead to issues
+ # and there have been long debates with upstream about it. :(
+ rm -rf /tmp/lept/ || die
+}
+
+multilib_src_install_all() {
+ # libtool archives covered by pkg-config.
+ find "${D}" -name "*.la" -delete || die
+}