summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-12 12:28:07 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-12 12:28:07 -0500
commit1cd69f33fd1511902a3c290087955d267c0f4233 (patch)
tree075fddcfd6e7b3edb1d0d40ca6db53e24f6cc788 /media-libs/libaom
parentmedia-libs/libaacs: Drop old versions (diff)
downloadgentoo-1cd69f33fd1511902a3c290087955d267c0f4233.tar.gz
gentoo-1cd69f33fd1511902a3c290087955d267c0f4233.tar.bz2
gentoo-1cd69f33fd1511902a3c290087955d267c0f4233.zip
media-libs/libaom: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libaom')
-rw-r--r--media-libs/libaom/Manifest1
-rw-r--r--media-libs/libaom/libaom-3.3.0.ebuild108
-rw-r--r--media-libs/libaom/libaom-3.4.0-r1.ebuild113
3 files changed, 0 insertions, 222 deletions
diff --git a/media-libs/libaom/Manifest b/media-libs/libaom/Manifest
index d9317b5b8cae..8f3af4916d3e 100644
--- a/media-libs/libaom/Manifest
+++ b/media-libs/libaom/Manifest
@@ -1,3 +1,2 @@
-DIST libaom-3.3.0.tar.gz 4768475 BLAKE2B 22060694019bcd925cb38c365063b8f2be60aed4cc6f9b0aa95cf8b4c4c5b40f5c603359d8c0728c5650fe9f7eea7573b8fd4a93975481c67409b201b4c48428 SHA512 9bd118bf46d777da4e85f348fed95510ce583d16d005d062d33e2899f16f24bdb8b120792a7c77ccb64b4e1ff5b3d934342fb1b356bb426693ef69220f138c5f
DIST libaom-3.4.0.tar.gz 5175838 BLAKE2B 7a38cc1a1871f044018a8ebf5022810b753b099ad61e0c6e2625a0480946e8b5e066fd1e1abc5523e817025c8a59d6f1092c12d632c5b602cf3a80f6ef8daa0e SHA512 8de5e7eae96b182ceb33ce2c66fde784349a7a117371177102c358cc9b2cad75bebe2849fdf8ce57ae149a38b43419b51e54e5475cb781ed3d5953081127b478
DIST libaom-3.5.0.tar.gz 5206715 BLAKE2B d47ddb864c909c972f692667177417daef0350124a096547eacc83ab3630227fe7a23e95f3988a2109c580f9a87ba30a58bcc58be1a2e24fe694eb01655a4861 SHA512 370c529a84d54c95f05c5a3b3edadd1cca95eeccd5a6b5454e574211c6dd9bf5bd33ab67b43587c6de37688fe546ea9e16de0ab2d721e965143b7e8c85db6fd4
diff --git a/media-libs/libaom/libaom-3.3.0.ebuild b/media-libs/libaom/libaom-3.3.0.ebuild
deleted file mode 100644
index 3cceed6f3e43..000000000000
--- a/media-libs/libaom/libaom-3.3.0.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake-multilib python-any-r1
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
-else
- SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
-fi
-
-DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
-HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
-
-LICENSE="BSD-2"
-SLOT="0/3"
-IUSE="doc +examples test"
-IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
-IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
-IUSE="${IUSE} cpu_flags_arm_neon"
-# Tests need more wiring up
-RESTRICT="!test? ( test ) test"
-
-REQUIRED_USE="
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
-"
-
-BDEPEND="${PYTHON_DEPS}
- abi_x86_32? ( dev-lang/yasm )
- abi_x86_64? ( dev-lang/yasm )
- abi_x86_x32? ( dev-lang/yasm )
- doc? ( app-doc/doxygen )
-"
-
-# the PATENTS file is required to be distributed with this package, bug #682214
-DOCS=( PATENTS )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_CCACHE=OFF
- -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
- -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
- -DENABLE_NASM=OFF
- -DENABLE_TESTS=$(usex test)
- -DENABLE_TOOLS=ON
- -DENABLE_WERROR=OFF
-
- # Needs libjxl, currently unpackaged.
- -DCONFIG_TUNE_BUTTERAUGLI=0
-
- # neon support is assumed to be always enabled on arm64
- -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
- # ENABLE_DSPR2 / ENABLE_MSA for mips
- -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
- -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
- -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
- -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
- -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
- -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
- -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
- -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
- -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
- )
-
- # For 32-bit multilib builds, force some intrinsics on to work around
- # bug #816027. libaom seems to do runtime detection for some targets
- # at least, so this isn't an issue.
- if ! multilib_is_native_abi && use amd64 ; then
- mycmakeargs+=(
- -DENABLE_SSE3=ON
- -DENABLE_SSSE3=ON
- )
- fi
-
- # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
- # Just force generic, given it's a niche situation.
- # TODO: could try forcing armv7 or similar?
- if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
- ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
- mycmakeargs+=(
- -DAOM_TARGET_CPU=generic
- )
- fi
-
- cmake_src_configure
-}
-
-multilib_src_test() {
- "${BUILD_DIR}"/test_libaom || die
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use doc ; then
- local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
- fi
-
- cmake_src_install
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
-}
diff --git a/media-libs/libaom/libaom-3.4.0-r1.ebuild b/media-libs/libaom/libaom-3.4.0-r1.ebuild
deleted file mode 100644
index 7c969b44ed77..000000000000
--- a/media-libs/libaom/libaom-3.4.0-r1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake-multilib python-any-r1
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
-else
- SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
-HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
-
-LICENSE="BSD-2"
-SLOT="0/3"
-IUSE="doc +examples test"
-IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
-IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
-IUSE="${IUSE} cpu_flags_arm_neon"
-# Tests need more wiring up
-RESTRICT="!test? ( test ) test"
-
-REQUIRED_USE="
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
-"
-
-BDEPEND="${PYTHON_DEPS}
- dev-lang/perl
- abi_x86_32? ( dev-lang/yasm )
- abi_x86_64? ( dev-lang/yasm )
- abi_x86_x32? ( dev-lang/yasm )
- doc? ( app-doc/doxygen )
-"
-
-# The PATENTS file is required to be distributed with this package, bug #682214
-DOCS=( PATENTS )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.4.0-posix-c-source-ftello.patch
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_CCACHE=OFF
- -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
- -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
- -DENABLE_NASM=OFF
- -DENABLE_TESTS=$(usex test)
- -DENABLE_TOOLS=ON
- -DENABLE_WERROR=OFF
-
- # Needs libjxl, currently unpackaged.
- -DCONFIG_TUNE_BUTTERAUGLI=0
-
- # neon support is assumed to be always enabled on arm64
- -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
- # ENABLE_DSPR2 / ENABLE_MSA for mips
- -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
- -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
- -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
- -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
- -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
- -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
- -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
- -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
- -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
- )
-
- # For 32-bit multilib builds, force some intrinsics on to work around
- # bug #816027. libaom seems to do runtime detection for some targets
- # at least, so this isn't an issue.
- if ! multilib_is_native_abi && use amd64 ; then
- mycmakeargs+=(
- -DENABLE_SSE3=ON
- -DENABLE_SSSE3=ON
- )
- fi
-
- # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
- # Just force generic, given it's a niche situation.
- # TODO: could try forcing armv7 or similar?
- if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
- ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
- mycmakeargs+=(
- -DAOM_TARGET_CPU=generic
- )
- fi
-
- cmake_src_configure
-}
-
-multilib_src_test() {
- "${BUILD_DIR}"/test_libaom || die
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use doc ; then
- local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
- fi
-
- cmake_src_install
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
-}