summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 13:14:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 18:56:40 +0100
commita54a2e6ceb4586e83c02f1cbab697e78f38df203 (patch)
tree0e6ecf4854ce5273447ab11c29d33c906b9b61b6 /media-libs/libaom
parentmedia-libs/libcuefile: EAPI-7 bump, use cmake.eclass (diff)
downloadgentoo-a54a2e6ceb4586e83c02f1cbab697e78f38df203.tar.gz
gentoo-a54a2e6ceb4586e83c02f1cbab697e78f38df203.tar.bz2
gentoo-a54a2e6ceb4586e83c02f1cbab697e78f38df203.zip
media-libs/libaom: 1.0.0-r2 EAPI-7 bump, use cmake.eclass
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libaom')
-rw-r--r--media-libs/libaom/libaom-1.0.0-r2.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/media-libs/libaom/libaom-1.0.0-r2.ebuild b/media-libs/libaom/libaom-1.0.0-r2.ebuild
index 7ff67cd2f15e..f4337dd9e190 100644
--- a/media-libs/libaom/libaom-1.0.0-r2.ebuild
+++ b/media-libs/libaom/libaom-1.0.0-r2.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == *9999* ]]; then
@@ -28,8 +30,12 @@ IUSE="doc examples"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_avx cpu_flags_x86_avx2"
IUSE="${IUSE} cpu_flags_arm_neon"
-RDEPEND=""
-DEPEND="abi_x86_32? ( dev-lang/yasm )
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="abi_x86_32? ( dev-lang/yasm )
abi_x86_64? ( dev-lang/yasm )
abi_x86_x32? ( dev-lang/yasm )
x86-fbsd? ( dev-lang/yasm )
@@ -37,11 +43,6 @@ DEPEND="abi_x86_32? ( dev-lang/yasm )
doc? ( app-doc/doxygen )
"
-REQUIRED_USE="
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
-"
-
PATCHES=(
"${FILESDIR}/libdirpc2.patch"
"${FILESDIR}/pthread_lib2.patch"
@@ -55,7 +56,7 @@ DOCS=( PATENTS )
src_prepare() {
sed -e 's/lib"/lib${LIB_SUFFIX}"/' -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
multilib_src_configure() {
@@ -77,17 +78,14 @@ multilib_src_configure() {
-DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
-
- -DBUILD_SHARED_LIBS=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
rm aom.pc # ensure it is rebuilt with proper libdir
}
multilib_src_install() {
- cmake-utils_src_install
if multilib_is_native_abi && use doc ; then
- docinto html
- dodoc docs/html/*
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
+ cmake_src_install
}