summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libcuefile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libcuefile')
-rw-r--r--media-libs/libcuefile/Manifest1
-rw-r--r--media-libs/libcuefile/libcuefile-477-r1.ebuild26
-rw-r--r--media-libs/libcuefile/libcuefile-477.ebuild24
-rw-r--r--media-libs/libcuefile/metadata.xml5
4 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/libcuefile/Manifest b/media-libs/libcuefile/Manifest
new file mode 100644
index 000000000000..19cbd6fdc408
--- /dev/null
+++ b/media-libs/libcuefile/Manifest
@@ -0,0 +1 @@
+DIST libcuefile-477.tar.xz 41676 SHA256 135e5c72165bf7a2a82b8d2bd54a01c2d5ea967df4e075d5bf7f0c56675e9edf SHA512 9cf46f9fd1b178758b2d15fa65d67d069bba41a83354a5aedf7b57ed5752bb68ad1d10208ffbb22f2aac7bd5d938e9395f67d4248441743d45e0099638d60d5e WHIRLPOOL 5f6f8d20154f355074f8caf806da3056c53f841ead4184cf115f18acd04142ce6fe1027f44648075ea8d8d72d725022c1d4428521c15ec2c262e0d4081a962e0
diff --git a/media-libs/libcuefile/libcuefile-477-r1.ebuild b/media-libs/libcuefile/libcuefile-477-r1.ebuild
new file mode 100644
index 000000000000..68cdfb37fd88
--- /dev/null
+++ b/media-libs/libcuefile/libcuefile-477-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib
+
+# svn export http://svn.musepack.net/libcuefile/trunk libcuefile-${PV}
+# tar -cJf libcuefile-${PV}.tar.xz libcuefile-${PV}
+
+DESCRIPTION="Cue File library from Musepack"
+HOMEPAGE="http://www.musepack.net/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r2
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+src_install() {
+ cmake-multilib_src_install
+ insinto /usr/include
+ doins -r include/cuetools
+}
diff --git a/media-libs/libcuefile/libcuefile-477.ebuild b/media-libs/libcuefile/libcuefile-477.ebuild
new file mode 100644
index 000000000000..25cf4effea5c
--- /dev/null
+++ b/media-libs/libcuefile/libcuefile-477.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils
+
+# svn export http://svn.musepack.net/libcuefile/trunk libcuefile-${PV}
+# tar -cJf libcuefile-${PV}.tar.xz libcuefile-${PV}
+
+DESCRIPTION="Cue File library from Musepack"
+HOMEPAGE="http://www.musepack.net/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/include
+ doins -r include/cuetools
+}
diff --git a/media-libs/libcuefile/metadata.xml b/media-libs/libcuefile/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-libs/libcuefile/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>