summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-11-30 14:10:57 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-12-03 22:13:50 +0000
commit445189d9c1db0f014dade3c13c1ef1fac9c480ab (patch)
treec66103dfc33243681c99dd1adbb4039d8bd31350 /media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
parentmedia-tv/linuxtv-dvb-apps: Newer snapshot, EAPI 6, cleanup (diff)
downloadgentoo-445189d9c1db0f014dade3c13c1ef1fac9c480ab.tar.gz
gentoo-445189d9c1db0f014dade3c13c1ef1fac9c480ab.tar.bz2
gentoo-445189d9c1db0f014dade3c13c1ef1fac9c480ab.zip
media-libs/libdvbcsa: New, imported from vdr-devel overlay
Needed by tvheadend. Setting myself as maintainer as hd_brummy seems to be MIA. Feel free to take it! Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild')
-rw-r--r--media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild b/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
new file mode 100644
index 000000000000..8c96eb334aa0
--- /dev/null
+++ b/media-libs/libdvbcsa/libdvbcsa-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free implementation of the DVB Common Scrambling Algorithm - DVB/CSA"
+HOMEPAGE="https://www.videolan.org/developers/libdvbcsa.html"
+SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug cpu_flags_x86_mmx cpu_flags_x86_sse2 static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable ppc altivec) \
+ $(use_enable debug) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable static-libs static) \
+ $(use_enable x86 uint32) \
+ $(use_enable amd64 uint64) \
+ --enable-shared
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}