summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-11-23 18:29:52 +0100
committerAmy Liffey <amynka@gentoo.org>2017-11-23 18:29:52 +0100
commitee80a96ccabc958b288bad61de4538d399f18101 (patch)
treea66b343ca6ad0a6cbe99c6ca4c5fb6c4341d1f2b /media-libs/libebur128/libebur128-1.2.3.ebuild
parentnet-libs/ldns: add patches to fix CVE-2017-1000231/1000232 (diff)
downloadgentoo-ee80a96ccabc958b288bad61de4538d399f18101.tar.gz
gentoo-ee80a96ccabc958b288bad61de4538d399f18101.tar.bz2
gentoo-ee80a96ccabc958b288bad61de4538d399f18101.zip
media-libs/libebur128: version bump 1.2.3
Closes: https://bugs.gentoo.org/638416 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'media-libs/libebur128/libebur128-1.2.3.ebuild')
-rw-r--r--media-libs/libebur128/libebur128-1.2.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libebur128/libebur128-1.2.3.ebuild b/media-libs/libebur128/libebur128-1.2.3.ebuild
new file mode 100644
index 000000000000..78247354eae7
--- /dev/null
+++ b/media-libs/libebur128/libebur128-1.2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library implementing the EBU R128 loudness standard"
+HOMEPAGE="https://github.com/jiixyj/libebur128"
+SRC_URI="https://github.com/jiixyj/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://tech.ebu.ch/files/live/sites/tech/files/shared/testmaterial/ebu-loudness-test-setv05.zip )"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( app-arch/unzip
+ media-libs/libsndfile[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cd "${WORKDIR}" || die
+ "${BUILD_DIR}"/r128-test-library | tee test-results
+ grep -c "^FAILED" test-results > /dev/null \
+ && die "At least one test failed"
+}