summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-12 19:07:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-13 10:33:25 +0100
commit68077e8e919bc50122949f64759be12376fb4b68 (patch)
tree89653b0d9b93d3d8913d35ec144e06820700a799 /media-libs/libextractor
parentmedia-gfx/freecad: Add no-webkit patch (diff)
downloadgentoo-68077e8e919bc50122949f64759be12376fb4b68.tar.gz
gentoo-68077e8e919bc50122949f64759be12376fb4b68.tar.bz2
gentoo-68077e8e919bc50122949f64759be12376fb4b68.zip
media-libs/libextractor: Non-maintainer security cleanup
Bug: https://bugs.gentoo.org/635362 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/libextractor')
-rw-r--r--media-libs/libextractor/Manifest1
-rw-r--r--media-libs/libextractor/files/libextractor-1.3-exiv2-0.26.patch27
-rw-r--r--media-libs/libextractor/files/libextractor-1.3-ffmpeg-2.9.patch52
-rw-r--r--media-libs/libextractor/files/libextractor-1.3-giflib-5.patch37
-rw-r--r--media-libs/libextractor/libextractor-1.3-r1.ebuild117
5 files changed, 0 insertions, 234 deletions
diff --git a/media-libs/libextractor/Manifest b/media-libs/libextractor/Manifest
index f7a0212670e0..3faadb8f17c2 100644
--- a/media-libs/libextractor/Manifest
+++ b/media-libs/libextractor/Manifest
@@ -1,2 +1 @@
-DIST libextractor-1.3.tar.gz 7942021 BLAKE2B 76856cd70b1981b95db55b7070d5e82574e8842f49dc3ee7cfc6f35f71b66f7b8e642b82cbbaa8446488ab29ca39c9792e4153f3cd9624dde731b3daefe2e86f SHA512 38ed47e5e5f50ddf216408f698a104900baa3b03cc8a81a14e63afd30b3e3922acda17363d88d9ba1356ebf70287c8a5152ff6933a36ec1042ca0d832218d45d
DIST libextractor-1.6.tar.gz 8053454 BLAKE2B cf5e9d5fd1bc09e20495810e5a85280916632eb1c5e5c6c68aaf1cbccb8a5970465d3fd6b313e0cfc7e5c262a815996d7bec563c04b04faf7467ddbe987dfb4c SHA512 1e477450d89cc83030100fc9dc11734f39b1ccd1765f8cf4a4938f32253e2e19a48b5337328605451589865142b2d6bf6d7102198115985a1e0da22fca4bc2a8
diff --git a/media-libs/libextractor/files/libextractor-1.3-exiv2-0.26.patch b/media-libs/libextractor/files/libextractor-1.3-exiv2-0.26.patch
deleted file mode 100644
index b6e0b41773b3..000000000000
--- a/media-libs/libextractor/files/libextractor-1.3-exiv2-0.26.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/src/plugins/exiv2_extractor.cc 2013-06-25 13:02:05.000000000 +0200
-+++ b/src/plugins/exiv2_extractor.cc 2017-06-10 14:22:57.000000000 +0200
-@@ -180,7 +180,11 @@
- *
- * @return -1 on error
- */
-+#if EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,26,0)
-+ virtual size_t size (void) const;
-+#else
- virtual long int size (void) const;
-+#endif
-
- /**
- * Check if file is open.
-@@ -445,7 +449,11 @@
- *
- * @return -1 on error
- */
--long int
-+#if EXIV2_VERSION >= EXIV2_MAKE_VERSION(0,26,0)
-+size_t
-+#else
-+long int
-+#endif
- ExtractorIO::size (void) const
- {
- return (long) ec->get_size (ec->cls);
diff --git a/media-libs/libextractor/files/libextractor-1.3-ffmpeg-2.9.patch b/media-libs/libextractor/files/libextractor-1.3-ffmpeg-2.9.patch
deleted file mode 100644
index d9e50b698ac8..000000000000
--- a/media-libs/libextractor/files/libextractor-1.3-ffmpeg-2.9.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Description: Replace deprecated FFmpeg API
-Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
-Last-Update: <2015-11-28>
-
---- libextractor-1.3.orig/src/plugins/thumbnailffmpeg_extractor.c
-+++ libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c
-@@ -153,7 +153,7 @@ seek_cb (void *opaque,
- static size_t
- create_thumbnail (int src_width, int src_height,
- int src_stride[],
-- enum PixelFormat src_pixfmt,
-+ enum AVPixelFormat src_pixfmt,
- const uint8_t * const src_data[],
- int dst_width, int dst_height,
- uint8_t **output_data,
-@@ -189,7 +189,7 @@ create_thumbnail (int src_width, int src
- if (NULL ==
- (scaler_ctx =
- sws_getContext (src_width, src_height, src_pixfmt,
-- dst_width, dst_height, PIX_FMT_RGB24,
-+ dst_width, dst_height, AV_PIX_FMT_RGB24,
- SWS_BILINEAR, NULL, NULL, NULL)))
- {
- #if DEBUG
-@@ -214,7 +214,7 @@ create_thumbnail (int src_width, int src
- return 0;
- }
- if (NULL == (dst_buffer =
-- av_malloc (avpicture_get_size (PIX_FMT_RGB24, dst_width, dst_height))))
-+ av_malloc (avpicture_get_size (AV_PIX_FMT_RGB24, dst_width, dst_height))))
- {
- #if DEBUG
- fprintf (stderr,
-@@ -229,7 +229,7 @@ create_thumbnail (int src_width, int src
- return 0;
- }
- avpicture_fill ((AVPicture *) dst_frame, dst_buffer,
-- PIX_FMT_RGB24, dst_width, dst_height);
-+ AV_PIX_FMT_RGB24, dst_width, dst_height);
- sws_scale (scaler_ctx,
- src_data,
- src_stride,
-@@ -272,7 +272,7 @@ create_thumbnail (int src_width, int src
- }
- encoder_codec_ctx->width = dst_width;
- encoder_codec_ctx->height = dst_height;
-- encoder_codec_ctx->pix_fmt = PIX_FMT_RGB24;
-+ encoder_codec_ctx->pix_fmt = AV_PIX_FMT_RGB24;
- opts = NULL;
- if (avcodec_open2 (encoder_codec_ctx, encoder_codec, &opts) < 0)
- {
-
diff --git a/media-libs/libextractor/files/libextractor-1.3-giflib-5.patch b/media-libs/libextractor/files/libextractor-1.3-giflib-5.patch
deleted file mode 100644
index 4893f9784a58..000000000000
--- a/media-libs/libextractor/files/libextractor-1.3-giflib-5.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://bugs.gentoo.org/571902
-
-------------------------------------------------------------------------
-r34095 | LRN | 2014-07-31 10:58:51 -0400 (Thu, 31 Jul 2014) | 1 line
-
-Add giflib-5.1.0 compatibility
-
-Index: src/plugins/gif_extractor.c
-===================================================================
---- a/src/plugins/gif_extractor.c (revision 34094)
-+++ b/src/plugins/gif_extractor.c (revision 34095)
-@@ -78,7 +78,11 @@ EXTRACTOR_gif_extract_method (struct EXT
- if (gif_file == NULL || gif_error != 0)
- {
- if (gif_file != NULL)
-+#if GIFLIB_MAJOR < 5 || GIFLIB_MINOR < 1
- EGifCloseFile (gif_file);
-+#else
-+ EGifCloseFile (gif_file, NULL);
-+#endif
- return; /* not a GIF */
- }
- #endif
-@@ -133,7 +137,11 @@ EXTRACTOR_gif_extract_method (struct EXT
- DGifGetExtensionNext(gif_file, &ext)) &&
- (NULL != ext) ) ; /* keep going */
- }
-+#if defined (GIF_LIB_VERSION) || GIFLIB_MAJOR < 5 || GIFLIB_MINOR < 1
- DGifCloseFile (gif_file);
-+#else
-+ DGifCloseFile (gif_file, NULL);
-+#endif
- }
-
- /* end of gif_extractor.c */
-
-------------------------------------------------------------------------
diff --git a/media-libs/libextractor/libextractor-1.3-r1.ebuild b/media-libs/libextractor/libextractor-1.3-r1.ebuild
deleted file mode 100644
index dc06475abc4f..000000000000
--- a/media-libs/libextractor/libextractor-1.3-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Library to extract metadata from files of arbitrary type"
-HOMEPAGE="https://www.gnu.org/software/libextractor/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="+archive +bzip2 ffmpeg flac gif gsf gtk jpeg +magic midi mp4 mpeg tidy tiff vorbis +zlib" # test
-
-RESTRICT="test"
-
-COMMON_DEPEND="
- app-text/iso-codes
- >=dev-libs/glib-2
- media-gfx/exiv2:=
- sys-devel/libtool
- virtual/libiconv
- virtual/libintl
- archive? ( app-arch/libarchive:= )
- bzip2? ( app-arch/bzip2 )
- ffmpeg? ( virtual/ffmpeg )
- flac? (
- media-libs/flac
- media-libs/libogg
- )
- gif? ( media-libs/giflib:= )
- gsf? ( gnome-extra/libgsf:= )
- gtk? ( x11-libs/gtk+:3 )
- jpeg? ( virtual/jpeg:0 )
- magic? ( sys-apps/file )
- midi? ( media-libs/libsmf )
- mp4? ( media-libs/libmp4v2:0 )
- mpeg? ( media-libs/libmpeg2 )
- tidy? ( app-text/htmltidy )
- tiff? ( media-libs/tiff:0 )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-# test? ( app-forensics/zzuf )
-RDEPEND="${COMMON_DEPEND}
- !sci-biology/glimmer
- !sci-chemistry/pdb-extract
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-giflib-5.patch #571902
- "${FILESDIR}"/${P}-ffmpeg-2.9.patch
- "${FILESDIR}"/${P}-exiv2-0.26.patch #621242
-)
-
-src_prepare() {
- default
-
- # m4/ax_create_pkgconfig_info.m4 is passing environment LDFLAGS to Libs:
- sed -i \
- -e '/^ax_create_pkgconfig_ldflags=/s:$LDFLAGS ::' \
- -e 's:tidy/tidy.h:tidy.h:' \
- -e 's:tidy/buffio.h:buffio.h:' \
- configure src/plugins/html_extractor.c || die
-
- if ! use tidy; then
- sed -i -e 's:tidy.h:dIsAbLe&:' configure || die
- fi
-}
-
-src_configure() {
- e_ac_cv() {
- export ac_cv_"$@"
- }
-
- e_ac_cv {lib_rpm_rpmReadPackageFile,prog_HAVE_ZZUF}=no
-
- e_ac_cv header_FLAC_all_h=$(usex flac)
- e_ac_cv lib_FLAC_FLAC__stream_decoder_init_stream=$(usex flac)
- e_ac_cv lib_FLAC_FLAC__stream_decoder_init_ogg_stream=$(usex flac)
-
- e_ac_cv header_archive_h=$(usex archive)
- e_ac_cv header_bzlib_h=$(usex bzip2)
- e_ac_cv header_gif_lib_h=$(usex gif)
- e_ac_cv header_jpeglib_h=$(usex jpeg)
- e_ac_cv header_magic_h=$(usex magic)
- e_ac_cv header_mpeg2dec_mpeg2_h=$(usex mpeg)
- e_ac_cv header_tiffio_h=$(usex tiff)
- e_ac_cv header_vorbis_vorbisfile_h=$(usex vorbis)
- e_ac_cv header_zlib_h=$(usex zlib)
- e_ac_cv lib_mp4v2_MP4ReadProvider=$(usex mp4)
- e_ac_cv lib_smf_smf_load_from_memory=$(usex midi)
-
- # gstreamer support is for 1.0, no 0.10 support
- econf \
- --disable-static \
- --enable-experimental \
- --enable-glib \
- --with-gtk_version=$(usex gtk 3.0.0 false) \
- --without-gstreamer \
- --disable-gsf-gnome \
- $(use_enable gsf) \
- $(use_enable ffmpeg)
-}
-
-src_install() {
- default
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}