summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-26 15:54:36 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-26 17:41:41 -0700
commit79c3c3652df8a25c05d94f9acaaf303a5ddca270 (patch)
treee2b049f7655f121d8f9340d3397b3567e2e719a9 /media-libs/libglvnd/libglvnd-1.0.0.20180524.ebuild
parentdev-db/rqlite: remove old (diff)
downloadgentoo-79c3c3652df8a25c05d94f9acaaf303a5ddca270.tar.gz
gentoo-79c3c3652df8a25c05d94f9acaaf303a5ddca270.tar.bz2
gentoo-79c3c3652df8a25c05d94f9acaaf303a5ddca270.zip
media-libs/libglvnd: Add package
package.mask'd for now. Bug: https://bugs.gentoo.org/606924
Diffstat (limited to 'media-libs/libglvnd/libglvnd-1.0.0.20180524.ebuild')
-rw-r--r--media-libs/libglvnd/libglvnd-1.0.0.20180524.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/libglvnd/libglvnd-1.0.0.20180524.ebuild b/media-libs/libglvnd/libglvnd-1.0.0.20180524.ebuild
new file mode 100644
index 000000000000..b1d53c3d68eb
--- /dev/null
+++ b/media-libs/libglvnd/libglvnd-1.0.0.20180524.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
+
+DESCRIPTION="The GL Vendor-Neutral Dispatch library"
+HOMEPAGE="https://github.com/NVIDIA/libglvnd"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ COMMIT="8709003ffdc905d144855c3117a31da220149d4c"
+ SRC_URI="https://github.com/NVIDIA/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${COMMIT}
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ !media-libs/mesa[-libglvnd(-)]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ "
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}