summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-08 19:42:38 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-12 12:05:59 +0300
commit5120e24cdc12a81a5717ea20b6e7897937dccc27 (patch)
tree50932c120fb18f243ec5c45ea3f0156df61e7795 /media-libs/libheif
parentmedia-libs/libheif: drop old (diff)
downloadgentoo-5120e24cdc12a81a5717ea20b6e7897937dccc27.tar.gz
gentoo-5120e24cdc12a81a5717ea20b6e7897937dccc27.tar.bz2
gentoo-5120e24cdc12a81a5717ea20b6e7897937dccc27.zip
media-libs/libheif: add missing media-libs/libaom dep
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/libheif')
-rw-r--r--media-libs/libheif/libheif-1.7.0-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/libheif/libheif-1.7.0-r2.ebuild b/media-libs/libheif/libheif-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..e54b807b2dfa
--- /dev/null
+++ b/media-libs/libheif/libheif-1.7.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.7"
+IUSE="gdk-pixbuf go static-libs test +threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+ >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}]
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ go? ( dev-lang/go )
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-aom.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' configure.ac || die
+
+ eautoreconf
+
+ # prevent "stat heif-test.go: no such file or directory"
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local econf_args=(
+ $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(use_enable gdk-pixbuf)
+ $(use_enable static-libs static)
+ $(use_enable threads multithreading)
+ )
+ ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}