summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo75@gmail.com>2020-02-11 16:37:30 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-26 12:49:01 +0100
commit57977e0d23776701bf3cb920cc4885f15d57179c (patch)
tree8d2a7ccdd6d300c87c99856f5ac4347fa5f8bd84 /media-libs/libiptcdata/libiptcdata-1.0.5.ebuild
parentdev-python/PythonQt: Fix BDEPEND/DEPEND (diff)
downloadgentoo-57977e0d23776701bf3cb920cc4885f15d57179c.tar.gz
gentoo-57977e0d23776701bf3cb920cc4885f15d57179c.tar.bz2
gentoo-57977e0d23776701bf3cb920cc4885f15d57179c.zip
media-libs/libiptcdata: 1.0.5 version bump
This version is ABI and API compatible (no code change) to version 1.0.4. However build system has been updated and it's now possible to use python 3 Closes: https://bugs.gentoo.org/708706 Signed-off-by: Francesco Riosa <vivo75@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14626 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libiptcdata/libiptcdata-1.0.5.ebuild')
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild
new file mode 100644
index 000000000000..e83c9fc1c5b4
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit python-single-r1
+
+DESCRIPTION="Library for International Press Telecommunications Council (IPTC) metadata"
+HOMEPAGE="https://github.com/ianw/libiptcdata http://libiptcdata.sourceforge.net"
+SRC_URI="https://github.com/ianw/${PN}/releases/download/release_1_0_5/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples nls python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.13.1 )
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure () {
+ local myeconfargs=( $(use_enable nls)
+ $(use_enable python)
+ $(use_enable doc gtk-doc) )
+ econf "${myeconfargs[@]}"
+}
+
+src_install () {
+ default
+
+ if use examples; then
+ dodoc python/README
+ dodoc -r python/examples
+ fi
+
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+}