summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-01-28 12:52:43 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-01-28 12:53:02 +0100
commit4422e2b87fa82116e44ae71240ae02f65f75fc75 (patch)
tree958332134c5131b64cddbe43ef899abab2d79c5e /media-libs/libkeyfinder
parentsys-devel/llvm: Bump to 12.0.0-rc1 (this time with ebuild) (diff)
downloadgentoo-4422e2b87fa82116e44ae71240ae02f65f75fc75.tar.gz
gentoo-4422e2b87fa82116e44ae71240ae02f65f75fc75.tar.bz2
gentoo-4422e2b87fa82116e44ae71240ae02f65f75fc75.zip
media-libs/libkeyfinder: bump to 2.2.4
by jospezial <jospezial@gmx.de> Closes: https://bugs.gentoo.org/767709 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/libkeyfinder')
-rw-r--r--media-libs/libkeyfinder/Manifest1
-rw-r--r--media-libs/libkeyfinder/libkeyfinder-2.2.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libkeyfinder/Manifest b/media-libs/libkeyfinder/Manifest
index 37c7a17c0762..3326d6090327 100644
--- a/media-libs/libkeyfinder/Manifest
+++ b/media-libs/libkeyfinder/Manifest
@@ -1 +1,2 @@
DIST libkeyfinder-2.2.3.tar.gz 117373 BLAKE2B a6d3ff64f26e0842c95dea125ae86f3c642db101fe934bf0a54a3586276cea1f2ee427e480e4f375067b80b2c9d9623f9276110371cc91c8b8d9319c92fd91d3 SHA512 7617bb7305854790e2d5fba5e401387612cad4fa61e9209a6af45301ee8dcc990c116e478c70a5d845d12fc6dfaf63362dca608f4774640bc6c29459ca192f45
+DIST libkeyfinder-2.2.4.tar.gz 79053 BLAKE2B 4d30931451625b00e1ecc2bfb6349497887ab805b5a986e05dbc51fb007a2aededcefbf9fc18c1beb7a7bc4e368c763a658979b5c5c6f7e91f4a21797ad414d7 SHA512 6673b9a81dbfa3693fc4e7af4e5fc0f351f0c60b00fdafeb9e3437e2f77b5fec7d1e78e3989ff1daca72770a1d3cdbe3837508718b8e8aba3ac3f3d56af81a56
diff --git a/media-libs/libkeyfinder/libkeyfinder-2.2.4.ebuild b/media-libs/libkeyfinder/libkeyfinder-2.2.4.ebuild
new file mode 100644
index 000000000000..b102bfc23bfe
--- /dev/null
+++ b/media-libs/libkeyfinder/libkeyfinder-2.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Musical key detection library for digital audio"
+HOMEPAGE="https://github.com/mixxxdj/libkeyfinder"
+SRC_URI="https://github.com/mixxxdj/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/fftw:3.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/NAMES fftw /NAMES /" \
+ cmake/FindFFTW3.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}