summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-06-22 15:17:52 -0600
committerTim Harder <radhermit@gentoo.org>2019-06-22 16:40:13 -0600
commitc3f0f4eb577defb61682f67c8f2ca2aa0ce2948e (patch)
tree320676859776d4ddf93c7ab232e98a61acd8d9f6 /media-libs/libmatroska/libmatroska-1.5.2.ebuild
parentdev-libs/libebml: remove old (diff)
downloadgentoo-c3f0f4eb577defb61682f67c8f2ca2aa0ce2948e.tar.gz
gentoo-c3f0f4eb577defb61682f67c8f2ca2aa0ce2948e.tar.bz2
gentoo-c3f0f4eb577defb61682f67c8f2ca2aa0ce2948e.zip
media-libs/libmatroska: version bump to 1.5.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-libs/libmatroska/libmatroska-1.5.2.ebuild')
-rw-r--r--media-libs/libmatroska/libmatroska-1.5.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/libmatroska/libmatroska-1.5.2.ebuild b/media-libs/libmatroska/libmatroska-1.5.2.ebuild
new file mode 100644
index 000000000000..6013ab8c473d
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-1.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libmatroska/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/6" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/libebml-1.3.9:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
+ cmake-utils_src_configure
+}