summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-09-17 22:39:30 +0300
committerLars Wendler <polynomial-c@gentoo.org>2016-12-26 17:09:02 +0100
commitcd82781cf798c237b750e0e34de965c3d04b3cab (patch)
treece76e4181eda8cb2da7f037f73f47d9e8d380ba7 /media-libs/libmygpo-qt/libmygpo-qt-1.0.9.ebuild
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-cd82781cf798c237b750e0e34de965c3d04b3cab.tar.gz
gentoo-cd82781cf798c237b750e0e34de965c3d04b3cab.tar.bz2
gentoo-cd82781cf798c237b750e0e34de965c3d04b3cab.zip
media-sound/libmygpo: version bump 1.0.9
Gentoo bug: 594118 Also this one removes some legacy code from live one. Closes: https://github.com/gentoo/gentoo/pull/2350
Diffstat (limited to 'media-libs/libmygpo-qt/libmygpo-qt-1.0.9.ebuild')
-rw-r--r--media-libs/libmygpo-qt/libmygpo-qt-1.0.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libmygpo-qt/libmygpo-qt-1.0.9.ebuild b/media-libs/libmygpo-qt/libmygpo-qt-1.0.9.ebuild
new file mode 100644
index 000000000000..af69ab287371
--- /dev/null
+++ b/media-libs/libmygpo-qt/libmygpo-qt-1.0.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Qt/C++ library wrapping the gpodder.net webservice"
+HOMEPAGE="http://wiki.gpodder.org/wiki/Libmygpo-qt"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/gpodder/libmygpo-qt.git"
+ KEYWORDS=""
+ SRC_URI=""
+ inherit git-2
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/gpodder/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-qt/qtcore:4
+ >=dev-libs/qjson-0.5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-qt/qttest:4 )"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test MYGPO_BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}