summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-08 05:31:13 -0500
committerSam James <sam@gentoo.org>2024-03-08 11:09:04 +0000
commit9359f1bf9cd9d9d16d27264e1e4981c92318df1b (patch)
tree10c233f2422f7752ca36eecce62d74565053b99a /media-libs/libmypaint
parentx11-libs/fox: drop fox-wrapper to an RDEPEND only (diff)
downloadgentoo-9359f1bf9cd9d9d16d27264e1e4981c92318df1b.tar.gz
gentoo-9359f1bf9cd9d9d16d27264e1e4981c92318df1b.tar.bz2
gentoo-9359f1bf9cd9d9d16d27264e1e4981c92318df1b.zip
media-libs/libmypaint: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libmypaint')
-rw-r--r--media-libs/libmypaint/libmypaint-1.6.1-r2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/libmypaint/libmypaint-1.6.1-r2.ebuild b/media-libs/libmypaint/libmypaint-1.6.1-r2.ebuild
index 3f6801855e38..47ae783200df 100644
--- a/media-libs/libmypaint/libmypaint-1.6.1-r2.ebuild
+++ b/media-libs/libmypaint/libmypaint-1.6.1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-any-r1 toolchain-funcs
+inherit libtool python-any-r1 toolchain-funcs
MY_PV=${PV/_beta/-beta.}
MY_P=${PN}-${MY_PV}
@@ -51,6 +51,11 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
tc-ld-disable-gold # bug 589266