summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-09-19 21:47:14 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-04 00:14:21 +0200
commit840dce2c7b99de72b1c6515d2ad334db3746758a (patch)
tree11408d86ea59f3dcdab43802a91ed896f85fbee7 /media-libs/libopenshot
parentmedia-video/openshot: version bump to 2.4.0 (diff)
downloadgentoo-840dce2c7b99de72b1c6515d2ad334db3746758a.tar.gz
gentoo-840dce2c7b99de72b1c6515d2ad334db3746758a.tar.bz2
gentoo-840dce2c7b99de72b1c6515d2ad334db3746758a.zip
media-libs/libopenshot: version bump to 0.1.8.
Closes: https://bugs.gentoo.org/631426 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/Manifest1
-rw-r--r--media-libs/libopenshot/files/libopenshot-0.1.8-fix-tests.patch26
-rw-r--r--media-libs/libopenshot/libopenshot-0.1.8.ebuild88
-rw-r--r--media-libs/libopenshot/metadata.xml9
4 files changed, 116 insertions, 8 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index 2b94907f7ac1..3a35d834afc0 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1,2 +1,3 @@
DIST libopenshot-0.1.3.tar.gz 11019740 SHA256 4a35318af4fbeeb0c658963275e8ec1edb985497ab9674d76eb02a1d72cbb64d SHA512 d59817505812868db408a88dc1d30b5b1833910f45dd0df03937110b7d4cbd85a270773008e75a1501f4b3b89a09ea798ed9b580755adf3ae79ac24d403f6982 WHIRLPOOL 31e7b7fe98e2709d1d88c6e2c39ceaa0b81c4f9a624ea9853ffd9b86771148e1bec808ec67192cede3578bc30860f8f5a878f67745d2d2ac9838ea93f01b628c
DIST libopenshot-0.1.7.tar.gz 11022594 SHA256 71cf5c18c76c36bec40c775cb98ab1ed672aa48d2de63a26c33c5cc5d6f0875a SHA512 4c8871ff30c03a14766e35a64052695768311afd81ecc55598720ad146f53c122ef3b1293467670f7dd48da77bf6cb4f4f14a18c298a649b8827f901ed653709 WHIRLPOOL 1730155af6b22ead4655e69c47df395566eb97dc66e5ec683ac2025130eded9060b515fd637b58de0254c4673adfbea1620a3253064f150fcb9bf9dfd492eb88
+DIST libopenshot-0.1.8.tar.gz 11019495 SHA256 a9b0706433c5c0e6edc9b1cc3c0ff1af4c8b7e8e31b5e071445a113fbb365d45 SHA512 02630d7ce9fd378ad648d034622d4f971728a2074691d7facc8a36dcd52b87c1372dd5a9588c0ba852589105bdbf78941083fd6b1eb1bcc0a33d4ca49634162c WHIRLPOOL ce007a69609ef34c3be0828d8b337a9eca795e5e806a056a3a391b804e438aa43063d80a7df0c42d31e79932c56eef5f55c17ebbd2fd846410c16bf227c6c844
diff --git a/media-libs/libopenshot/files/libopenshot-0.1.8-fix-tests.patch b/media-libs/libopenshot/files/libopenshot-0.1.8-fix-tests.patch
new file mode 100644
index 000000000000..bad8bcb9b4f0
--- /dev/null
+++ b/media-libs/libopenshot/files/libopenshot-0.1.8-fix-tests.patch
@@ -0,0 +1,26 @@
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 431987b..2c45550 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -24,16 +24,19 @@
+ # along with OpenShot Library. If not, see <http://www.gnu.org/licenses/>.
+ ################################################################################
+
++SET(TEST_MEDIA_PATH "${openshot_SOURCE_DIR}/src/examples/")
+
+ ################ WINDOWS ##################
+ # Set some compiler options for Windows
+ # required for libopenshot-audio headers
+ IF (WIN32)
+- STRING(REPLACE "/" "\\\\" TEST_MEDIA_PATH "${openshot_SOURCE_DIR}/src/examples/")
+- add_definitions( -DIGNORE_JUCE_HYPOT=1 -DTEST_MEDIA_PATH="${TEST_MEDIA_PATH}" )
++ STRING(REPLACE "/" "\\\\" TEST_MEDIA_PATH TEST_MEDIA_PATH)
++ add_definitions( -DIGNORE_JUCE_HYPOT=1 )
+ SET(CMAKE_CXX_FLAGS " ${CMAKE_CXX_FLAGS} -include cmath")
+ ENDIF(WIN32)
+
++add_definitions( -DTEST_MEDIA_PATH="${TEST_MEDIA_PATH}" )
++
+ ################### UNITTEST++ #####################
+ # Find UnitTest++ libraries (used for unit testing)
+ FIND_PACKAGE(UnitTest++ REQUIRED)
diff --git a/media-libs/libopenshot/libopenshot-0.1.8.ebuild b/media-libs/libopenshot/libopenshot-0.1.8.ebuild
new file mode 100644
index 000000000000..b663cdc7ff24
--- /dev/null
+++ b/media-libs/libopenshot/libopenshot-0.1.8.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-single-r1 toolchain-funcs versionator
+
+DESCRIPTION="Video editing library used by OpenShot"
+HOMEPAGE="http://www.openshotvideo.com/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+imagemagick libav +python test"
+# https://github.com/OpenShot/libopenshot/issues/43
+RESTRICT="test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ net-libs/cppzmq
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ media-libs/libopenshot-audio
+ imagemagick? ( <media-gfx/imagemagick-7:0=[cxx] )
+ libav? ( media-video/libav:=[encode,x264,xvid,vpx,mp3,theora] )
+ !libav? ( media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+ test? ( dev-libs/unittest++ )
+"
+
+# https://github.com/OpenShot/libopenshot/pull/45
+PATCHES=( ${FILESDIR}/${PN}-0.1.8-fix-tests.patch )
+
+check_compiler() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
+pkg_pretend() {
+ check_compiler
+}
+
+pkg_setup() {
+ check_compiler
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # https://github.com/OpenShot/libopenshot/issues/17
+ use test || cmake_comment_add_subdirectory tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_RUBY=OFF # TODO: add ruby support
+ -DENABLE_PYTHON=$(usex python)
+ $(cmake-utils_use_find_package imagemagick ImageMagick)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_make test
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize
+}
diff --git a/media-libs/libopenshot/metadata.xml b/media-libs/libopenshot/metadata.xml
index 27f9c3bcefe5..2f5ef7858c7c 100644
--- a/media-libs/libopenshot/metadata.xml
+++ b/media-libs/libopenshot/metadata.xml
@@ -1,14 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>sautier.louis@gmail.com</email>
- <name>Louis Sautier</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="launchpad">libopenshot</remote-id>
<remote-id type="github">OpenShot/libopenshot</remote-id>