summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 12:19:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 12:22:41 +0100
commitca8c063c6680e56ca3d26b4ea776df1742be5db8 (patch)
tree2fdcbf79b76383ec5168f8d1f8841b1000d21338 /media-libs/libqaccessibilityclient/files
parentprofiles: hppa: Consolidate virtual/mpi revdeps p.use.stable.mask (diff)
downloadgentoo-ca8c063c6680e56ca3d26b4ea776df1742be5db8.tar.gz
gentoo-ca8c063c6680e56ca3d26b4ea776df1742be5db8.tar.bz2
gentoo-ca8c063c6680e56ca3d26b4ea776df1742be5db8.zip
media-libs/libqaccessibilityclient: 0.3.0 version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libqaccessibilityclient/files')
-rw-r--r--media-libs/libqaccessibilityclient/files/libqaccessibilityclient-0.3.0-tests.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libqaccessibilityclient/files/libqaccessibilityclient-0.3.0-tests.patch b/media-libs/libqaccessibilityclient/files/libqaccessibilityclient-0.3.0-tests.patch
new file mode 100644
index 000000000000..1ec1317ea80f
--- /dev/null
+++ b/media-libs/libqaccessibilityclient/files/libqaccessibilityclient-0.3.0-tests.patch
@@ -0,0 +1,37 @@
+From a85bce953b8a231cfe9b47d9f3fd80f6149f51f2 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 18 Nov 2018 12:13:28 +0100
+Subject: [PATCH] Use standard BUILD_TESTING instead of BUILD_TESTS
+
+Add tests subdir conditionally.
+---
+ CMakeLists.txt | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 73bb3cb..13531cc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -34,7 +34,7 @@ include_directories(
+ find_package(Qt5Widgets QUIET)
+ find_package(Qt5DBus QUIET)
+ find_package(Qt5Test QUIET)
+-set(BUILD_TESTS ${Qt5Test_FOUND})
++set(BUILD_TESTING ${Qt5Test_FOUND})
+
+ add_definitions(${Qt5Core_DEFINITIONS} ${Qt5Widgets_DEFINITIONS} ${Qt5DBus_DEFINITIONS})
+ include_directories(${Qt5Core_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS} ${Qt5DBus_INCLUDE_DIRS})
+@@ -70,7 +70,9 @@ if(APPLE)
+ endif(APPLE)
+
+ add_subdirectory(src)
+-add_subdirectory(tests)
++if(BUILD_TESTING)
++ add_subdirectory(tests)
++endif()
+ add_subdirectory(examples)
+
+ # we need the absolute directories where stuff will be installed too
+--
+2.19.1
+