summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libsfml/libsfml-1.6-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libsfml/libsfml-1.6-r1.ebuild')
-rw-r--r--media-libs/libsfml/libsfml-1.6-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libsfml/libsfml-1.6-r1.ebuild b/media-libs/libsfml/libsfml-1.6-r1.ebuild
new file mode 100644
index 000000000000..fc3cfb6d930c
--- /dev/null
+++ b/media-libs/libsfml/libsfml-1.6-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="SFML-${PV}"
+DESCRIPTION="Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="http://www.sfml-dev.org/"
+SRC_URI="mirror://sourceforge/sfml/${MY_P}-sdk-linux-32.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples static-libs"
+
+DEPEND="media-libs/freetype:2
+ media-libs/glew
+ >=media-libs/libpng-1.4
+ media-libs/libsndfile
+ media-libs/mesa
+ media-libs/openal
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXrandr"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-destdir.patch \
+ "${FILESDIR}"/${P}-deps-and-flags.patch \
+ "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="$myconf DEBUGBUILD=yes"
+
+ emake $myconf CPP=$(tc-getCXX) CC=$(tc-getCC)
+ use static-libs && emake $myconf STATIC=yes CPP=$(tc-getCXX) CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr libdir=/usr/$(get_libdir) install
+
+ use static-libs && dolib.a lib/*.a
+ use doc && dohtml doc/html/*
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ local i
+ for i in ftp opengl pong post-fx qt sockets sound sound_capture voip window wxwidgets X11 ; do
+ insinto /usr/share/doc/${PF}/examples/$i
+ doins samples/$i/*
+ done
+ fi
+}