summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-18 11:17:45 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-18 11:19:54 +0100
commit433bc75f1a644664d42a83c10f26330325c3542c (patch)
tree6ad7ecbfcd466a3a3db5d7114c598c01fe13a4df /media-libs/libshout
parentadd slot deps (diff)
downloadgentoo-433bc75f1a644664d42a83c10f26330325c3542c.tar.gz
gentoo-433bc75f1a644664d42a83c10f26330325c3542c.tar.bz2
gentoo-433bc75f1a644664d42a83c10f26330325c3542c.zip
media-libs/libshout: Bump to version 2.4.1
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/libshout')
-rw-r--r--media-libs/libshout/Manifest1
-rw-r--r--media-libs/libshout/files/libshout-2.4.1-underlinking.patch13
-rw-r--r--media-libs/libshout/libshout-2.4.1.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/libshout/Manifest b/media-libs/libshout/Manifest
index e80f9bde7aa2..163684662191 100644
--- a/media-libs/libshout/Manifest
+++ b/media-libs/libshout/Manifest
@@ -1 +1,2 @@
DIST libshout-2.3.1.tar.gz 464229 SHA256 cf3c5f6b4a5e3fcfbe09fb7024aa88ad4099a9945f7cb037ec06bcee7a23926e SHA512 19c1421e654310ddbc25f343d205d921b7c3f1c9c97f028207deaf1a46150b7f6c8069d52b7a3c9ed72dda276b52237cf1208292fbfa09aa7d09f85072c46a7b WHIRLPOOL 7060612fc19735030d8da4ef340eb51ef6d3cbb44502a64ba68f87cc4031918e304bd1f317dfe5796937ef0eeed2dad13abaa622bdca774d65e23f5ae2a061fa
+DIST libshout-2.4.1.tar.gz 516161 SHA256 f3acb8dec26f2dbf6df778888e0e429a4ce9378a9d461b02a7ccbf2991bbf24d SHA512 4d4b958947e020de3330d49d39d59220fc89315f25f653a7456b9aa24ca9566fca30bb3d65e6348e79958656096b6b864ea8885157d24e55c8d84d6604670219 WHIRLPOOL b2c4d9e4e6cebe01879fedd5edbe158f8011fd55140df98f3993101875b991cf236a5d6b8545e947ac3d55fcfc24a9fe4afd2a567b9eace372a23282b4b5e6af
diff --git a/media-libs/libshout/files/libshout-2.4.1-underlinking.patch b/media-libs/libshout/files/libshout-2.4.1-underlinking.patch
new file mode 100644
index 000000000000..0c6b7f2f5a71
--- /dev/null
+++ b/media-libs/libshout/files/libshout-2.4.1-underlinking.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/499458
+
+--- libshout-2.4.1/src/Makefile.am
++++ libshout-2.4.1/src/Makefile.am
+@@ -33,7 +33,7 @@
+ AM_CFLAGS = @XIPH_CFLAGS@
+
+ libshout_la_LIBADD = common/net/libicenet.la common/timing/libicetiming.la common/avl/libiceavl.la\
+- common/httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS) $(SPEEX_LIBS) @XIPH_LIBS@
++ common/httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(OGG_LIBS) $(VORBIS_LIBS) $(THEORA_LIBS) $(SPEEX_LIBS) @XIPH_LIBS@
+
+ INCLUDES = -I$(top_builddir)/include -I./common/
+
diff --git a/media-libs/libshout/libshout-2.4.1.ebuild b/media-libs/libshout/libshout-2.4.1.ebuild
new file mode 100644
index 000000000000..10160a8a7ae5
--- /dev/null
+++ b/media-libs/libshout/libshout-2.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="library for connecting and sending data to icecast servers"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="libressl speex static-libs theora"
+
+RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r6
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.1-underlinking.patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable theora) \
+ $(use_enable speex)
+}
+
+multilib_src_install_all() {
+ dodoc README examples/example.c
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files
+}