summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-04-12 09:09:06 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-04-12 09:09:14 +0200
commit80d2e63fb042ef14e627ba3081789034ac74a275 (patch)
tree1b63684b8c1707b8985249252827086be7b57731 /media-libs/libshout
parentnet-fs/samba: fix race condition during build (diff)
downloadgentoo-80d2e63fb042ef14e627ba3081789034ac74a275.tar.gz
gentoo-80d2e63fb042ef14e627ba3081789034ac74a275.tar.bz2
gentoo-80d2e63fb042ef14e627ba3081789034ac74a275.zip
media-libs/libshout: bump to 2.4.6
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/libshout')
-rw-r--r--media-libs/libshout/Manifest1
-rw-r--r--media-libs/libshout/libshout-2.4.6.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libshout/Manifest b/media-libs/libshout/Manifest
index a5ef52ece889..79266e7a3d6d 100644
--- a/media-libs/libshout/Manifest
+++ b/media-libs/libshout/Manifest
@@ -1 +1,2 @@
DIST libshout-2.4.5.tar.gz 543991 BLAKE2B a3ceabd150413e9d1cee2118fe9576959bfa05d86e261b2574969a9a665aba3da4ac1c39db2b27d033fe587232a69a569d80362f856bba667277b5454dd170ca SHA512 290844185da16961f03434d3e341573dd6cb0139e5fa81902903021b641382d2629302d7c356bc591b35656754e07f4e44a8d9e782e092b17a051b9ae8f54341
+DIST libshout-2.4.6.tar.gz 571153 BLAKE2B 68a24ecd3fa8c1057883d2d9013b18b9b7507d0ee79876efe79c8ad1ae32c408421879340968b77c3d6bf6e8eb3c3c87a8ee5447f351fd871f13683fcbb5ab52 SHA512 e8478cdbf9a27674c16a7b620d1576f2e31a47262b8e29b314d0f46d4e5be24b9a29790b7b226f48939bc34cacf5734fae0aa5686c7ed5879cdbd827ff8e0339
diff --git a/media-libs/libshout/libshout-2.4.6.ebuild b/media-libs/libshout/libshout-2.4.6.ebuild
new file mode 100644
index 000000000000..39e327e11c39
--- /dev/null
+++ b/media-libs/libshout/libshout-2.4.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="library for connecting and sending data to icecast servers"
+HOMEPAGE="https://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="speex static-libs theora"
+
+RDEPEND="
+ >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ dev-libs/openssl:0=
+ speex? ( media-libs/speex[${MULTILIB_USEDEP}] )
+ theora? ( media-libs/libtheora[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/shout/shout.h
+)
+
+src_prepare() {
+ default
+ # Fix docdir
+ sed '/^docdir/s@$(PACKAGE)@$(PF)@' -i Makefile.am || die
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable speex)
+ $(use_enable static-libs static)
+ $(use_enable theora)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}