summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-06-23 16:11:41 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-06-23 16:15:01 +0900
commit1ecc27856c6d64b94e094a64e78f207815d3122a (patch)
tree5045c9311f720e6aa6fbc62b0362082d548a4f64 /media-libs/libsixel
parentdev-python/python-axolotl-curve25519: Revert "Initial commit." (diff)
downloadgentoo-1ecc27856c6d64b94e094a64e78f207815d3122a.tar.gz
gentoo-1ecc27856c6d64b94e094a64e78f207815d3122a.tar.bz2
gentoo-1ecc27856c6d64b94e094a64e78f207815d3122a.zip
media-libs/libsixel: new upstream release
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/libsixel')
-rw-r--r--media-libs/libsixel/Manifest1
-rw-r--r--media-libs/libsixel/libsixel-1.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
index 73cc65595e6d..f3b457923189 100644
--- a/media-libs/libsixel/Manifest
+++ b/media-libs/libsixel/Manifest
@@ -1,2 +1,3 @@
DIST libsixel-1.7.2.tar.gz 4760634 BLAKE2B 0cf1de06a133a018e4bc5d6d5fbceb07e33e4246b826c28c2e1f3251a383a9fddc7255c1b8726c0f4d13b41bbd42e9188e3d442cc65c399004628f3d7a020dd4 SHA512 9716ec45ba29cab6603896f717a6b21111ebacb48744009c8c032d6fd8dbb8f7444f27bc9f5c6f419a771544582ce5828e6b1870ea2cc37d917030c4c88de091
DIST libsixel-1.7.3.tar.gz 4766335 BLAKE2B 5e546d31f9d66f5121301abe009677d05fbc1444e8a25a1feb6f9fed646a4bc543492376302b663569e0ddca99b665d5c81d9d35aa07349935b727ad581fb517 SHA512 f7b6b9748389f140ce2f6cf0eeb74ab5063c21455c72013a7e066981439bb1ada7b3e9b68a7b3b57c49205271f32ffb8d6d002a4f2af45b1381dd015873b4e91
+DIST libsixel-1.8.1.tar.gz 4777791 BLAKE2B de96029990acc00e0c5fa81e6f892153000a93841b8e152ecc2ae3db0e7ca1dbe5063fdbf69f79f23c82095b253206c7bea0f638ed7536ebcf3d0d23a1137965 SHA512 af38b47aac443bfb443aa7b12041ecc1496722afbc861ad8572e90c34c7c1ed4ee04241d5d5f3abb7d8be945fac2a1f718494c4fbd023a6a7b9f6d912f90554c
diff --git a/media-libs/libsixel/libsixel-1.8.1.ebuild b/media-libs/libsixel/libsixel-1.8.1.ebuild
new file mode 100644
index 000000000000..12cd9a6cec32
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ --disable-python
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ cd images
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+}