summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libsixel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libsixel')
-rw-r--r--media-libs/libsixel/Manifest2
-rw-r--r--media-libs/libsixel/libsixel-1.4.12.ebuild45
-rw-r--r--media-libs/libsixel/libsixel-1.4.13.ebuild45
-rw-r--r--media-libs/libsixel/metadata.xml10
4 files changed, 102 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
new file mode 100644
index 000000000000..f9e751b0e15a
--- /dev/null
+++ b/media-libs/libsixel/Manifest
@@ -0,0 +1,2 @@
+DIST libsixel-1.4.12.tar.gz 4060158 SHA256 79ba3ed747aa5c02b28d16540bd399e9dfa897b824731584b664c6f9f3ef7148 SHA512 e210bff8a1944bdb0baa33e5cce402965bc82d776ed4e1a92ecc78063e9174ffa418ac7852560ccdddfdbca1fe215f34257efb42f36b5954ffa1d5f87c6d85fc WHIRLPOOL 396472c753b6fccdd69f62e95d5ba0d6d5c4eaf5f1e946f9142649ea8f222a71611250e4ce36cd5745f3a7ceddfaae2750cf0cb507e4ce5bc5225c4baeaea764
+DIST libsixel-1.4.13.tar.gz 4061302 SHA256 9f69097ee798807038c39345c5f596b2d12a22cef16690e701a0fab77cab7b63 SHA512 668ed894986473d63386f2c867029fa74e4f56b57a9ab993d93340a802aab1842359d7600950d95d11e47e41725c1e04284d6b5142e1263e8c7285dcbf344336 WHIRLPOOL 882a5b9280092d16940a6b0b85df8ea87e8fef87b773ce066555ae32b63ac68d991a1912d8311ce254c1f66ce4ca359b904e6c56c3c9a5df5bd955f07ab564a1
diff --git a/media-libs/libsixel/libsixel-1.4.12.ebuild b/media-libs/libsixel/libsixel-1.4.12.ebuild
new file mode 100644
index 000000000000..a002b935ad70
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.4.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png)
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/images
+ dodoc -r images
+}
diff --git a/media-libs/libsixel/libsixel-1.4.13.ebuild b/media-libs/libsixel/libsixel-1.4.13.ebuild
new file mode 100644
index 000000000000..6358dc9ccd95
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.4.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png)
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/images
+ dodoc -r images
+}
diff --git a/media-libs/libsixel/metadata.xml b/media-libs/libsixel/metadata.xml
new file mode 100644
index 000000000000..3e259b9d2149
--- /dev/null
+++ b/media-libs/libsixel/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">saitoha/libsixel</remote-id>
+ </upstream>
+</pkgmetadata>