summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libtiger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libtiger')
-rw-r--r--media-libs/libtiger/Manifest1
-rw-r--r--media-libs/libtiger/files/libtiger-0.3.3-check.patch17
-rw-r--r--media-libs/libtiger/libtiger-0.3.4.ebuild36
-rw-r--r--media-libs/libtiger/metadata.xml11
4 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/libtiger/Manifest b/media-libs/libtiger/Manifest
new file mode 100644
index 000000000000..872c1b975d09
--- /dev/null
+++ b/media-libs/libtiger/Manifest
@@ -0,0 +1 @@
+DIST libtiger-0.3.4.tar.gz 383685 SHA256 7342b255fb476d75b08dd4c56d5ce580f39b1c71c42e99fb7af9d999725d4166 SHA512 559e522b5127f32fdd08d62c40dfb493dc2db1efd1e21707d723ef27cbe03e7e38fb04d40856d824ed0c3c94a223ed1a0358fc11ecb30446b5ee5c7a3b802e6d WHIRLPOOL 8b5234d35c8ed882b52395883ecbbcfba2bf4f92b8d85e274476837b515615847deaaa55a3f617b630413bc6c6baf613030c9ec194394a73836f1cb3498b2a2a
diff --git a/media-libs/libtiger/files/libtiger-0.3.3-check.patch b/media-libs/libtiger/files/libtiger-0.3.3-check.patch
new file mode 100644
index 000000000000..bcb32b683096
--- /dev/null
+++ b/media-libs/libtiger/files/libtiger-0.3.3-check.patch
@@ -0,0 +1,17 @@
+http://git.xiph.org/?p=users/oggk/tiger.git;a=commitdiff;h=3233686e501163f38cc28425827b901e258bfcc3
+fixes tests on eg arm.
+
+Index: libtiger-0.3.3/Makefile.in
+===================================================================
+--- libtiger-0.3.3.orig/Makefile.in
++++ libtiger-0.3.3/Makefile.in
+@@ -991,8 +991,7 @@ check-local:
+ @echo " Checking Tiger namespace"
+ @! @NM@ -B lib/.libs/*.a lib/.libs/*.so \
+ | $(GREP) "^[0-9a-z]\{8\} [A-MO-Z] [^\.]" \
+- | $(GREP) -vE " (_DYNAMIC|_init|_fini|_edata|_end|__bss_start)$$" \
+- | $(GREP) -vE " _(rest|save)[fg]pr_[0-9]*(|_x)$$" \
++ | $(GREP) -v "^.\{11\}_" \
+ | $(GREP) -v "^.\{11\}tiger_"
+ @echo " Checking memory allocation routines"
+ @! $(GREP) -EHn '[^_](malloc|realloc|free|calloc|memalign)\(' \
diff --git a/media-libs/libtiger/libtiger-0.3.4.ebuild b/media-libs/libtiger/libtiger-0.3.4.ebuild
new file mode 100644
index 000000000000..7724b3350499
--- /dev/null
+++ b/media-libs/libtiger/libtiger-0.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool
+
+DESCRIPTION="A rendering library for Kate streams using Pango and Cairo"
+HOMEPAGE="http://code.google.com/p/libtiger/"
+SRC_URI="http://libtiger.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/pango
+ >=media-libs/libkate-0.2.0
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable doc) --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc THANKS README ChangeLog AUTHORS
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/media-libs/libtiger/metadata.xml b/media-libs/libtiger/metadata.xml
new file mode 100644
index 000000000000..f8d4166ac6fd
--- /dev/null
+++ b/media-libs/libtiger/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <longdescription lang="en">libtiger is a rendering library for Kate streams using Pango and Cairo.
+ More information about Kate streams may be found at
+ http://wiki.xiph.org/index.php/OggKate</longdescription>
+ <upstream>
+ <remote-id type="google-code">libtiger</remote-id>
+ </upstream>
+</pkgmetadata>