summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-01-24 17:28:22 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 17:28:22 +0100
commite563243979926f3f8d1404df5bc1df684cd82dde (patch)
tree77fdd5f974c0df2a6205a3147bed556a8e2a657f /media-libs/libvisual/libvisual-0.4.0-r3.ebuild
parentsci-mathematics/gmp-ecm: restore dropped ~arm{,64} (diff)
downloadgentoo-e563243979926f3f8d1404df5bc1df684cd82dde.tar.gz
gentoo-e563243979926f3f8d1404df5bc1df684cd82dde.tar.bz2
gentoo-e563243979926f3f8d1404df5bc1df684cd82dde.zip
media-libs/libvisual: Port to EAPI 7
Closes: https://bugs.gentoo.org/517578 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/libvisual/libvisual-0.4.0-r3.ebuild')
-rw-r--r--media-libs/libvisual/libvisual-0.4.0-r3.ebuild50
1 files changed, 27 insertions, 23 deletions
diff --git a/media-libs/libvisual/libvisual-0.4.0-r3.ebuild b/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
index 50f3ac50b8e7..f6880e33b6ce 100644
--- a/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
+++ b/media-libs/libvisual/libvisual-0.4.0-r3.ebuild
@@ -1,27 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-AUTOTOOLS_AUTORECONF=1
+inherit autotools multilib-minimal
-inherit autotools-multilib
-
-DESCRIPTION="Libvisual is an abstraction library that comes between applications and audio visualisation plugins"
+DESCRIPTION="Abstraction library between applications and audio visualisation plugins"
HOMEPAGE="http://libvisual.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0.4"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="debug nls static-libs threads"
-
-DEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig"
+IUSE="debug nls threads"
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${P}-better-altivec-detection.patch
@@ -29,24 +24,33 @@ PATCHES=(
"${FILESDIR}"/${P}-conditions.patch
"${FILESDIR}"/${P}-detect_amd64.patch
"${FILESDIR}"/${P}-cond.patch
- )
+ "${FILESDIR}"/${P}-format-security.patch
+)
MULTILIB_WRAPPED_HEADERS=(
/usr/include/libvisual-0.4/libvisual/lvconfig.h
)
src_prepare() {
- autotools-multilib_src_prepare
+ default
+
# autogenerated, causes problems for out of tree builds
- rm -f libvisual/lvconfig.h || die
+ rm libvisual/lvconfig.h || die
+
+ eautoreconf
}
-src_configure() {
- local myeconfargs=(
- --enable-shared
- $(use_enable nls)
- $(use_enable threads)
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(use_enable nls) \
+ $(use_enable threads) \
$(use_enable debug)
- )
- autotools-multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}