summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-26 12:27:16 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-26 18:03:02 +0100
commit0614c44475793213f4d21c8f5c8b84977a6a1956 (patch)
treef23594f1f5e41a69bcae5c226f76d66a63c031fd /media-libs/libvpx/libvpx-1.5.0.ebuild
parentapp-portage/grs: remove variable from HOMEPAGE (diff)
downloadgentoo-0614c44475793213f4d21c8f5c8b84977a6a1956.tar.gz
gentoo-0614c44475793213f4d21c8f5c8b84977a6a1956.tar.bz2
gentoo-0614c44475793213f4d21c8f5c8b84977a6a1956.zip
media-libs/libvpx: security cleanup
Bug: https://bugs.gentoo.org/701834 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/14129 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/libvpx/libvpx-1.5.0.ebuild')
-rw-r--r--media-libs/libvpx/libvpx-1.5.0.ebuild127
1 files changed, 0 insertions, 127 deletions
diff --git a/media-libs/libvpx/libvpx-1.5.0.ebuild b/media-libs/libvpx/libvpx-1.5.0.ebuild
deleted file mode 100644
index 700c5256f736..000000000000
--- a/media-libs/libvpx/libvpx-1.5.0.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib toolchain-funcs multilib-minimal
-
-LIBVPX_TESTDATA_VER=1.5.0
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://chromium.googlesource.com/webm/${PN}.git"
-elif [[ ${PV} == *pre* ]]; then
- SRC_URI="mirror://gentoo/${P}.tar.bz2"
- KEYWORDS="amd64 arm arm64 ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-else
- SRC_URI="https://storage.googleapis.com/downloads.webmproject.org/releases/webm/${P}.tar.bz2"
- KEYWORDS="amd64 arm arm64 ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-# generated by: make LIBVPX_TEST_DATA_PATH=libvpx-testdata testdata + tar'ing
-# it.
-SRC_URI="${SRC_URI}
- test? ( mirror://gentoo/${PN}-testdata-${LIBVPX_TESTDATA_VER}.tar.bz2 )"
-
-DESCRIPTION="WebM VP8 Codec SDK"
-HOMEPAGE="https://www.webmproject.org"
-
-LICENSE="BSD"
-SLOT="0/3"
-IUSE="cpu_flags_x86_avx cpu_flags_x86_avx2 doc cpu_flags_x86_mmx postproc cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 static-libs svc test +threads"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="abi_x86_32? ( dev-lang/yasm )
- abi_x86_64? ( dev-lang/yasm )
- abi_x86_x32? ( dev-lang/yasm )
- x86-fbsd? ( dev-lang/yasm )
- amd64-fbsd? ( dev-lang/yasm )
- doc? (
- app-doc/doxygen
- dev-lang/php
- )
-"
-
-REQUIRED_USE="
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
-"
-
-src_prepare() {
- epatch "${FILESDIR}/libvpx-1.3.0-sparc-configure.patch" # 501010
-}
-
-multilib_src_configure() {
- unset CODECS #357487
-
- # let the build system decide which AS to use (it honours $AS but
- # then feeds it with yasm flags without checking...) #345161
- tc-export AS
- case "${CHOST}" in
- i?86*) export AS=yasm;;
- x86_64*) export AS=yasm;;
- esac
-
- # https://bugs.gentoo.org/show_bug.cgi?id=384585
- # https://bugs.gentoo.org/show_bug.cgi?id=465988
- # copied from php-pear-r1.eclass
- addpredict /usr/share/snmp/mibs/.index
- addpredict /var/lib/net-snmp/
- addpredict /var/lib/net-snmp/mib_indexes
- addpredict /session_mm_cli0.sem
-
- # Build with correct toolchain.
- tc-export CC CXX AR NM
- # Link with gcc by default, the build system should override this if needed.
- export LD="${CC}"
-
- local myconf
- if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
- myconf+=" $(use_enable doc install-docs) $(use_enable doc docs)"
- else
- # not needed for multilib and will be overwritten anyway.
- myconf+=" --disable-examples --disable-install-docs --disable-docs"
- fi
-
- # https://bugs.gentoo.org/569146
- export LC_COLLATE=C
-
- # #498364: sse doesn't work without sse2 enabled,
- "${S}/configure" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-pic \
- --enable-vp8 \
- --enable-vp9 \
- --enable-shared \
- --extra-cflags="${CFLAGS}" \
- $(use_enable cpu_flags_x86_avx avx) \
- $(use_enable cpu_flags_x86_avx2 avx2) \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable postproc) \
- $(use cpu_flags_x86_sse2 && use_enable cpu_flags_x86_sse sse || echo --disable-sse) \
- $(use_enable cpu_flags_x86_sse2 sse2) \
- $(use_enable cpu_flags_x86_sse3 sse3) \
- $(use_enable cpu_flags_x86_sse4_1 sse4_1) \
- $(use_enable cpu_flags_x86_ssse3 ssse3) \
- $(use_enable svc experimental) $(use_enable svc spatial-svc) \
- $(use_enable static-libs static) \
- $(use_enable test unit-tests) \
- $(use_enable threads multithread) \
- ${myconf} \
- || die
-}
-
-multilib_src_compile() {
- # build verbose by default and do not build examples that will not be installed
- emake verbose=yes GEN_EXAMPLES=
-}
-
-multilib_src_test() {
- LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" \
- emake verbose=yes GEN_EXAMPLES= LIBVPX_TEST_DATA_PATH="${WORKDIR}/${PN}-testdata" test
-}
-
-multilib_src_install() {
- emake verbose=yes GEN_EXAMPLES= DESTDIR="${D}" install
- [ "${ABI}" = "${DEFAULT_ABI}" ] && use doc && dohtml docs/html/*
-}