summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-18 17:11:14 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-18 17:12:14 -0400
commit808cbd7400602ae010e5ab0dcdaf8db9cfa87a99 (patch)
tree254962ef9a316e78d7b6b0f9987643e4676ec465 /media-libs/libxmlbird
parentkde-misc/kdeconnect: Lower dependency on kde-frameworks/kwayland (diff)
downloadgentoo-808cbd7400602ae010e5ab0dcdaf8db9cfa87a99.tar.gz
gentoo-808cbd7400602ae010e5ab0dcdaf8db9cfa87a99.tar.bz2
gentoo-808cbd7400602ae010e5ab0dcdaf8db9cfa87a99.zip
media-libs/libxmlbird & media-gfx/birdfont: switch to doit
Use the system version of doit so we can get parallel build support. The tiny bundled wrapper can only build serially.
Diffstat (limited to 'media-libs/libxmlbird')
-rw-r--r--media-libs/libxmlbird/files/libxmlbird-1.2.0-verbose.patch10
-rw-r--r--media-libs/libxmlbird/libxmlbird-1.2.0.ebuild8
2 files changed, 5 insertions, 13 deletions
diff --git a/media-libs/libxmlbird/files/libxmlbird-1.2.0-verbose.patch b/media-libs/libxmlbird/files/libxmlbird-1.2.0-verbose.patch
deleted file mode 100644
index b44a28de2303..000000000000
--- a/media-libs/libxmlbird/files/libxmlbird-1.2.0-verbose.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/scripts/run.py
-+++ b/scripts/run.py
-@@ -20,6 +20,7 @@ import subprocess
-
- def run(cmd):
- cmd = "sh -c \"" + cmd.replace ("\"", "\\\"") + "\""
-+ print(cmd)
- process = subprocess.Popen (cmd, shell=True)
- process.communicate()[0]
- if not process.returncode == 0:
diff --git a/media-libs/libxmlbird/libxmlbird-1.2.0.ebuild b/media-libs/libxmlbird/libxmlbird-1.2.0.ebuild
index 0934a67798a4..d321727547a1 100644
--- a/media-libs/libxmlbird/libxmlbird-1.2.0.ebuild
+++ b/media-libs/libxmlbird/libxmlbird-1.2.0.ebuild
@@ -5,7 +5,7 @@ EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit python-any-r1 vala toolchain-funcs multilib eutils
+inherit python-any-r1 vala toolchain-funcs multilib eutils multiprocessing
DESCRIPTION="XML parser written in Vala"
HOMEPAGE="https://birdfont.org/xmlbird.php"
@@ -19,10 +19,12 @@ IUSE=""
# The test build logic needs work. Doesn't respect compiler settings.
RESTRICT="test"
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/doit[${PYTHON_USEDEP}]')"
+
src_prepare() {
vala_src_prepare
- epatch "${FILESDIR}"/${PN}-1.2.0-verbose.patch
epatch "${FILESDIR}"/${PN}-1.2.0-configure-valac.patch
epatch "${FILESDIR}"/${PN}-1.2.0-libdir.patch
@@ -50,7 +52,7 @@ src_configure() {
}
src_compile() {
- v ./build.py
+ v doit run -n $(makeopts_jobs)
}
src_install() {