summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-09 11:25:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-09 11:25:24 +0200
commit3dc7547dfa9e9609c2904698c4867c3bb8885b4b (patch)
tree1d8d4a4395a171f154c672c474bbd527170cdefd /media-libs/libyami/libyami-9999.ebuild
parentdev-ros/openni2_camera: bump to 0.2.7 (diff)
downloadgentoo-3dc7547dfa9e9609c2904698c4867c3bb8885b4b.tar.gz
gentoo-3dc7547dfa9e9609c2904698c4867c3bb8885b4b.tar.bz2
gentoo-3dc7547dfa9e9609c2904698c4867c3bb8885b4b.zip
media-libs/libyami: bump to 0.4.0 and update live ebuild
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-libs/libyami/libyami-9999.ebuild')
-rw-r--r--media-libs/libyami/libyami-9999.ebuild45
1 files changed, 16 insertions, 29 deletions
diff --git a/media-libs/libyami/libyami-9999.ebuild b/media-libs/libyami/libyami-9999.ebuild
index 3951d2f79326..ad517708968c 100644
--- a/media-libs/libyami/libyami-9999.ebuild
+++ b/media-libs/libyami/libyami-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,36 +24,25 @@ else
S="${WORKDIR}/${PN}-${P}"
fi
-LICENSE="LGPL-2.1"
+LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+capi debug dmabuf doc ffmpeg gles +glx libav md5 tools v4l X"
+IUSE="+capi debug dmabuf doc md5 v4l X test"
RDEPEND="
- >=x11-libs/libva-1.6[drm,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/libva-1.7[drm,X?,${MULTILIB_USEDEP}]
v4l? (
- glx? (
- >=x11-libs/libva-1.6[X,${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=virtual/opengl-7[${MULTILIB_USEDEP}]
- )
- !glx? ( >=media-libs/mesa-10[egl,${MULTILIB_USEDEP}] )
+ >=virtual/opengl-7[${MULTILIB_USEDEP}]
>=media-libs/libv4l-1.6.2[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}]
)
X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
- ffmpeg? (
- !libav? ( media-video/ffmpeg:0=[${MULTILIB_USEDEP}] )
- libav? ( media-video/libav:=[${MULTILIB_USEDEP}] )
- )
md5? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
dmabuf? ( x11-libs/libdrm[${MULTILIB_USEDEP}] )
- tools? (
- gles? ( >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}] )
- v4l? ( !glx? ( >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}] ) )
- )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )
+ test? ( >=dev-cpp/gtest-1.7 )
"
src_prepare() {
@@ -63,27 +52,25 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable debug) \
- $(multilib_native_use_enable tools tests) \
- $(use gles && multilib_native_use_enable tools tests-gles) \
$(use_enable v4l v4l2) \
- $(usex v4l $(use_enable glx v4l2-glx) "--disable-v4l2-glx") \
+ $(use_enable v4l v4l2-ops) \
$(use_enable capi) \
$(use_enable X x11) \
$(use_enable dmabuf) \
- $(use_enable ffmpeg avformat) \
$(use_enable md5) \
+ $(use_enable test gtest) \
$(multilib_native_use_enable doc docs) \
+ --enable-h265dec \
+ --enable-vc1dec \
+ --enable-h264dec \
+ --enable-jpegdec \
+ --enable-mpeg2dec \
--enable-vp8dec \
--enable-vp9dec \
- --enable-jpegdec \
- --enable-h264dec \
- --disable-h265dec \
+ --enable-h265enc \
--enable-h264enc \
--enable-jpegenc \
- --enable-vp8enc \
- --enable-h265enc
-
- # h265 decoder doesnt build here with gcc 5.2
+ --enable-vp8enc
}
multilib_src_compile() {