summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-30 09:45:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-30 09:52:43 +0200
commitb6aeb1cce5b8f6dd1c50f9c29852214da39a52d3 (patch)
tree077a5cdb33aae9cfddf2efa914a1de8a1d510c0f /media-libs/mesa/mesa-9999.ebuild
parentdev-lang/swig: remove old 2.0.12 (diff)
downloadgentoo-b6aeb1cce5b8f6dd1c50f9c29852214da39a52d3.tar.gz
gentoo-b6aeb1cce5b8f6dd1c50f9c29852214da39a52d3.tar.bz2
gentoo-b6aeb1cce5b8f6dd1c50f9c29852214da39a52d3.zip
media-libs/mesa: Add missing LLVM_SLOT in llvm_check_deps()
Reported-by: Tim Harder <radhermit@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index d1efde2b6aa7..0fd4ae716a5f 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -247,9 +247,9 @@ llvm_check_deps() {
fi
if use opencl; then
- has_version "sys-devel/clang[${flags}]" || return 1
+ has_version "sys-devel/clang:${LLVM_SLOT}[${flags}]" || return 1
fi
- has_version "sys-devel/llvm[${flags}]"
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${flags}]"
}
pkg_pretend() {