summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-04-28 16:18:19 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-04-28 16:18:19 +0200
commitbac272fa3584c4483a8b42c346011d083c5a2dfe (patch)
tree4885f9ae724b95b157ed3ed378d44306f1eaf0ed /media-libs/mesa/mesa-9999.ebuild
parentapp-admin/puppet-agent: cleanup bug 581372 (diff)
downloadgentoo-bac272fa3584c4483a8b42c346011d083c5a2dfe.tar.gz
gentoo-bac272fa3584c4483a8b42c346011d083c5a2dfe.tar.bz2
gentoo-bac272fa3584c4483a8b42c346011d083c5a2dfe.zip
media-libs/mesa: add flag for vc4 driver
Bug: https://bugs.gentoo.org/show_bug.cgi?id=559144 Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 00213165a443..bf3dbcc6831b 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -37,7 +37,7 @@ RESTRICT="!bindist? ( bindist )"
INTEL_CARDS="i915 i965 ilo intel"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} freedreno nouveau vmware"
+VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} freedreno nouveau vc4 vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -120,7 +120,7 @@ RDEPEND="
vdpau? ( >=x11-libs/libvdpau-1.1:=[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.2.0:=[${MULTILIB_USEDEP}] )
xvmc? ( >=x11-libs/libXvMC-1.0.8:=[${MULTILIB_USEDEP}] )
- ${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_nouveau?,video_cards_vmware?,${MULTILIB_USEDEP}]
+ ${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_nouveau?,video_cards_vc4?,video_cards_vmware?,${MULTILIB_USEDEP}]
"
for card in ${INTEL_CARDS}; do
RDEPEND="${RDEPEND}
@@ -238,6 +238,7 @@ multilib_src_configure() {
use vaapi && myconf+=" --with-va-libdir=/usr/$(get_libdir)/va/drivers"
gallium_enable swrast
+ gallium_enable video_cards_vc4 vc4
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
gallium_enable video_cards_i915 i915