summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-03-06 13:05:36 -0800
committerMatt Turner <mattst88@gentoo.org>2017-03-06 13:06:21 -0800
commit430d112b8e4a475e3279c80f2f80a087a05c83a6 (patch)
tree6d1bfd37231c44ee0d314f77bf1b5f8a1322739f /media-libs/mesa
parentmedia-libs/mesa: Drop empty KEYWORDS="" assignment. (diff)
downloadgentoo-430d112b8e4a475e3279c80f2f80a087a05c83a6.tar.gz
gentoo-430d112b8e4a475e3279c80f2f80a087a05c83a6.tar.bz2
gentoo-430d112b8e4a475e3279c80f2f80a087a05c83a6.zip
media-libs/mesa: Require virtual/libelf for r600+llvm.
Bug: https://bugs.gentoo.org/611732
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-13.0.5.ebuild6
-rw-r--r--media-libs/mesa/mesa-17.0.1.ebuild6
-rw-r--r--media-libs/mesa/mesa-9999.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/media-libs/mesa/mesa-13.0.5.ebuild b/media-libs/mesa/mesa-13.0.5.ebuild
index 9b2276ac9b14..8aa4db9db5a5 100644
--- a/media-libs/mesa/mesa-13.0.5.ebuild
+++ b/media-libs/mesa/mesa-13.0.5.ebuild
@@ -96,6 +96,12 @@ RDEPEND="
video_cards_radeonsi? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
+ video_cards_r600? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
+ video_cards_radeon? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
>=sys-devel/llvm-3.6.0:0=[${MULTILIB_USEDEP}]
)
nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
diff --git a/media-libs/mesa/mesa-17.0.1.ebuild b/media-libs/mesa/mesa-17.0.1.ebuild
index 0b64e5b84bfb..699313f62e68 100644
--- a/media-libs/mesa/mesa-17.0.1.ebuild
+++ b/media-libs/mesa/mesa-17.0.1.ebuild
@@ -101,6 +101,12 @@ RDEPEND="
sys-devel/llvm:4[${MULTILIB_USEDEP}]
>=sys-devel/llvm-3.9.0:0[${MULTILIB_USEDEP}] ) )
)
+ video_cards_r600? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
+ video_cards_radeon? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
|| (
sys-devel/llvm:4[${MULTILIB_USEDEP}]
>=sys-devel/llvm-3.6.0:0[${MULTILIB_USEDEP}]
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index eb7f52a7f46c..15ce6d4cbd15 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -99,6 +99,12 @@ RDEPEND="
virtual/libelf:0=[${MULTILIB_USEDEP}]
vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
)
+ video_cards_r600? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
+ video_cards_radeon? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
opencl? (