summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-20 11:55:03 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-20 11:55:10 +0200
commit53a7fa538de8828dad35b18bb316367ffdc8a00d (patch)
tree72ca18846bb626df5a48588a67cd5f0c09d1ca9b /media-libs/mutagen/mutagen-1.31.ebuild
parentmail-mta/postfix: Stable for HPPA PPC64 (bug #560110). (diff)
downloadgentoo-53a7fa538de8828dad35b18bb316367ffdc8a00d.tar.gz
gentoo-53a7fa538de8828dad35b18bb316367ffdc8a00d.tar.bz2
gentoo-53a7fa538de8828dad35b18bb316367ffdc8a00d.zip
media-libs/mutagen: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'media-libs/mutagen/mutagen-1.31.ebuild')
-rw-r--r--media-libs/mutagen/mutagen-1.31.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/mutagen/mutagen-1.31.ebuild b/media-libs/mutagen/mutagen-1.31.ebuild
new file mode 100644
index 000000000000..621947a93e66
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.31.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="https://bitbucket.org/lazka/mutagen https://pypi.python.org/pypi/mutagen"
+SRC_URI="https://bitbucket.org/lazka/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# TODO: Missing support for >=dev-python/eyeD3-0.7 API
+# test? ( >=dev-python/eyeD3-0.7 )
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+src_test() {
+ # tests/test_flac.py uses temp files with a constant path.
+ # If we had multiple python implementations, we would hit a race.
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+ use doc && local HTML_DOCS=( docs/_build/. )
+ distutils-r1_python_install_all
+}