summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-10-09 13:47:34 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-10-09 13:47:50 +0200
commitb2d22c28d3193e38e0f685762d9f662f972b6558 (patch)
tree0af80404d86494b9eb4670422deebce44e02ada7 /media-libs/mutagen
parentnet-libs/libhtp: remove old (diff)
downloadgentoo-b2d22c28d3193e38e0f685762d9f662f972b6558.tar.gz
gentoo-b2d22c28d3193e38e0f685762d9f662f972b6558.tar.bz2
gentoo-b2d22c28d3193e38e0f685762d9f662f972b6558.zip
media-libs/mutagen: bump to 1.45.1 (+py3.9, new docs dep)
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/mutagen')
-rw-r--r--media-libs/mutagen/Manifest1
-rw-r--r--media-libs/mutagen/mutagen-1.45.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/mutagen/Manifest b/media-libs/mutagen/Manifest
index a79bcd75a63c..b656b83c3ebb 100644
--- a/media-libs/mutagen/Manifest
+++ b/media-libs/mutagen/Manifest
@@ -1,2 +1,3 @@
DIST mutagen-1.43.0.tar.gz 1143839 BLAKE2B 044906b730763e001fa2cb863c8bb1fec45713aca57b6311f783f66218e4f3410987d04d56a1e4fbf41a229860bbb574b4077401e1f2384e70d80fdc9f3b23ad SHA512 66df63705a43befa9cf6688bc8b3acc4fd1559eb28920c105b47a97c35422b5e19527051445daa7aed66facc2e4c14d71058f8560bbd564fecbe56a076491e3f
DIST mutagen-1.44.0.tar.gz 1143320 BLAKE2B 9e4ad11b7ee560a4940e3eaaecdb8b0fad4db54fd1fa9e4f925d84e55c217eb002e07602817fa92f6db9fdd6b6b339d5e147874bf587604c18b665d980d6604a SHA512 88c8c181b1333989451533951727b7c43e4a012defd3fd1f7ddd970d083f938783d61f98970e74c677ee9725dac92c47ee37af4bd7a474e85c7a56793c6063a8
+DIST mutagen-1.45.1.tar.gz 1285455 BLAKE2B a1e29698d96b4c98f16e18dd8b3f902e41dcc4409d01da861a726a6a9fbd7f116e07b4e1872b8b3857f0eec080d18bac736de741635746f5c71416a3a8ef6e78 SHA512 c5244efa01b9de5ec22ceca39e55f34b933ca4a5bec0f2088fd3adca657f0230cbe85cd5e156db1d90fb44d9339bc94dc3bdcd3e49f1b0d46bc3d71ece6b45d8
diff --git a/media-libs/mutagen/mutagen-1.45.1.ebuild b/media-libs/mutagen/mutagen-1.45.1.ebuild
new file mode 100644
index 000000000000..a4cddd5a2b20
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.45.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="https://github.com/quodlibet/mutagen https://pypi.org/project/mutagen/"
+SRC_URI="https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# TODO: Missing support for >=dev-python/eyeD3-0.7 API
+# test? ( >=dev-python/eyeD3-0.7 )
+BDEPEND="
+ doc? (
+ dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ )
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ esetup.py test --no-quality
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+ use doc && local HTML_DOCS=( docs/_build/. )
+ distutils-r1_python_install_all
+}