summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-11-07 17:43:43 +0000
committerAmy Winston <amynka@gentoo.org>2016-11-08 07:52:08 +0100
commita6629e1c0dbbbc67db09b096ca7a2c54eae73dc1 (patch)
tree5832ac0e2ce891ed32c89296633c1db89ea045b4 /media-libs/opencv/files
parentmedia-libs/opencv: revision bump to 3.1.0-r6 (diff)
downloadgentoo-a6629e1c0dbbbc67db09b096ca7a2c54eae73dc1.tar.gz
gentoo-a6629e1c0dbbbc67db09b096ca7a2c54eae73dc1.tar.bz2
gentoo-a6629e1c0dbbbc67db09b096ca7a2c54eae73dc1.zip
media-libs/opencv: Remove old ebuilds and patches Some ebuilds don't work, so there's no point in keeping them.
Since OpenCV 3.0.0 is no longer in the tree, the following can be closed: Gentoo-bug: 566080 Gentoo-bug: 557328 Signed-off by: Jonathan Scruggs (j.scruggs@gmail.com)
Diffstat (limited to 'media-libs/opencv/files')
-rw-r--r--media-libs/opencv/files/opencv-2.4.11-git-autodetect.patch57
-rw-r--r--media-libs/opencv/files/opencv-3.0.0-git-autodetect.patch41
-rw-r--r--media-libs/opencv/files/opencv-3.1.0-fix-hal-headers.patch91
-rw-r--r--media-libs/opencv/files/opencv-3.1.0-fix-ocl-declaration.patch214
-rw-r--r--media-libs/opencv/files/opencv-3.1.0-invalid-string-usage.patch75
-rw-r--r--media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch392
6 files changed, 0 insertions, 870 deletions
diff --git a/media-libs/opencv/files/opencv-2.4.11-git-autodetect.patch b/media-libs/opencv/files/opencv-2.4.11-git-autodetect.patch
deleted file mode 100644
index 12a5ca04e271..000000000000
--- a/media-libs/opencv/files/opencv-2.4.11-git-autodetect.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- opencv-2.4.11/work/opencv-2.4.11/CMakeLists.txt.old 2016-04-07 14:20:23.874972922 +0200
-+++ opencv-2.4.11/work/opencv-2.4.11/CMakeLists.txt 2016-04-07 14:21:15.689970743 +0200
-@@ -382,32 +382,32 @@
- # ----------------------------------------------------------------------------
-
- # don't use FindGit because it requires CMake 2.8.2
--set(git_names git eg) # eg = easy git
-+#set(git_names git eg) # eg = easy git
- # Prefer .cmd variants on Windows unless running in a Makefile in the MSYS shell
--if(CMAKE_HOST_WIN32)
-- if(NOT CMAKE_GENERATOR MATCHES "MSYS")
-- set(git_names git.cmd git eg.cmd eg)
-- endif()
--endif()
-+#if(CMAKE_HOST_WIN32)
-+# if(NOT CMAKE_GENERATOR MATCHES "MSYS")
-+# set(git_names git.cmd git eg.cmd eg)
-+# endif()
-+#endif()
-
--find_host_program(GIT_EXECUTABLE NAMES ${git_names} PATH_SUFFIXES Git/cmd Git/bin DOC "git command line client")
--mark_as_advanced(GIT_EXECUTABLE)
-+#find_host_program(GIT_EXECUTABLE NAMES ${git_names} PATH_SUFFIXES Git/cmd Git/bin DOC "git command line client")
-+#mark_as_advanced(GIT_EXECUTABLE)
-
--if(GIT_EXECUTABLE)
-- execute_process(COMMAND ${GIT_EXECUTABLE} describe --tags --always --dirty --match "2.[0-9].[0-9]*"
-- WORKING_DIRECTORY "${OpenCV_SOURCE_DIR}"
-- OUTPUT_VARIABLE OPENCV_VCSVERSION
-- RESULT_VARIABLE GIT_RESULT
-- ERROR_QUIET
-- OUTPUT_STRIP_TRAILING_WHITESPACE
-- )
-- if(NOT GIT_RESULT EQUAL 0)
-- set(OPENCV_VCSVERSION "unknown")
-- endif()
--else()
-+#if(GIT_EXECUTABLE)
-+# execute_process(COMMAND ${GIT_EXECUTABLE} describe --tags --always --dirty --match "2.[0-9].[0-9]*"
-+# WORKING_DIRECTORY "${OpenCV_SOURCE_DIR}"
-+# OUTPUT_VARIABLE OPENCV_VCSVERSION
-+# RESULT_VARIABLE GIT_RESULT
-+# ERROR_QUIET
-+# OUTPUT_STRIP_TRAILING_WHITESPACE
-+# )
-+# if(NOT GIT_RESULT EQUAL 0)
-+# set(OPENCV_VCSVERSION "unknown")
-+# endif()
-+#else()
- # We don't have git:
-- set(OPENCV_VCSVERSION "unknown")
--endif()
-+# set(OPENCV_VCSVERSION "unknown")
-+#endif()
-
-
- # ----------------------------------------------------------------------------
diff --git a/media-libs/opencv/files/opencv-3.0.0-git-autodetect.patch b/media-libs/opencv/files/opencv-3.0.0-git-autodetect.patch
deleted file mode 100644
index 741307592f29..000000000000
--- a/media-libs/opencv/files/opencv-3.0.0-git-autodetect.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- opencv-3.0.0/work/opencv-3.0.0/CMakeLists.txt.old 2016-04-07 14:28:07.641953419 +0200
-+++ opencv-3.0.0/work/opencv-3.0.0/CMakeLists.txt 2016-04-07 14:28:47.713951734 +0200
-@@ -433,23 +433,23 @@
- # ----------------------------------------------------------------------------
- # Autodetect if we are in a GIT repository
- # ----------------------------------------------------------------------------
--find_host_package(Git QUIET)
-+#find_host_package(Git QUIET)
-
--if(GIT_FOUND)
-- execute_process(COMMAND "${GIT_EXECUTABLE}" describe --tags --always --dirty --match "[0-9].[0-9].[0-9]*"
-- WORKING_DIRECTORY "${OpenCV_SOURCE_DIR}"
-- OUTPUT_VARIABLE OPENCV_VCSVERSION
-- RESULT_VARIABLE GIT_RESULT
-- ERROR_QUIET
-- OUTPUT_STRIP_TRAILING_WHITESPACE
-- )
-- if(NOT GIT_RESULT EQUAL 0)
-- set(OPENCV_VCSVERSION "unknown")
-- endif()
--else()
-+#if(GIT_FOUND)
-+# execute_process(COMMAND "${GIT_EXECUTABLE}" describe --tags --always --dirty --match "[0-9].[0-9].[0-9]*"
-+# WORKING_DIRECTORY "${OpenCV_SOURCE_DIR}"
-+# OUTPUT_VARIABLE OPENCV_VCSVERSION
-+# RESULT_VARIABLE GIT_RESULT
-+# ERROR_QUIET
-+# OUTPUT_STRIP_TRAILING_WHITESPACE
-+# )
-+# if(NOT GIT_RESULT EQUAL 0)
-+# set(OPENCV_VCSVERSION "unknown")
-+# endif()
-+#else()
- # We don't have git:
-- set(OPENCV_VCSVERSION "unknown")
--endif()
-+# set(OPENCV_VCSVERSION "unknown")
-+#endif()
-
-
- # ----------------------------------------------------------------------------
diff --git a/media-libs/opencv/files/opencv-3.1.0-fix-hal-headers.patch b/media-libs/opencv/files/opencv-3.1.0-fix-hal-headers.patch
deleted file mode 100644
index dd77571a60cf..000000000000
--- a/media-libs/opencv/files/opencv-3.1.0-fix-hal-headers.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From f529a1df2b17bcada1179ddcaf1352e3a5ba97b8 Mon Sep 17 00:00:00 2001
-From: Maksim Shabunin <maksim.shabunin@itseez.com>
-Date: Tue, 15 Dec 2015 17:51:08 +0300
-Subject: [PATCH] Fixed HAL headers location
-
-diff --git opencv_contrib-master/modules/xfeatures2d/src/sift.cpp opencv_contrib-master/modules/xfeatures2d/src/sift.cpp
-index fc67c4d..9634fbb 100644
---- opencv_contrib-master/modules/xfeatures2d/src/sift.cpp
-+++ opencv_contrib-master/modules/xfeatures2d/src/sift.cpp
-@@ -105,6 +105,7 @@
- #include "precomp.hpp"
- #include <iostream>
- #include <stdarg.h>
-+#include <opencv2/core/hal/hal.hpp>
-
- namespace cv
- {
-@@ -337,9 +338,9 @@ static float calcOrientationHist( const Mat& img, Point pt, int radius,
- len = k;
-
- // compute gradient values, orientations and the weights over the pixel neighborhood
-- hal::exp(W, W, len);
-- hal::fastAtan2(Y, X, Ori, len, true);
-- hal::magnitude(X, Y, Mag, len);
-+ cv::hal::exp32f(W, W, len);
-+ cv::hal::fastAtan2(Y, X, Ori, len, true);
-+ cv::hal::magnitude32f(X, Y, Mag, len);
-
- for( k = 0; k < len; k++ )
- {
-@@ -620,9 +621,9 @@ static void calcSIFTDescriptor( const Mat& img, Point2f ptf, float ori, float sc
- }
-
- len = k;
-- hal::fastAtan2(Y, X, Ori, len, true);
-- hal::magnitude(X, Y, Mag, len);
-- hal::exp(W, W, len);
-+ cv::hal::fastAtan2(Y, X, Ori, len, true);
-+ cv::hal::magnitude32f(X, Y, Mag, len);
-+ cv::hal::exp32f(W, W, len);
-
- for( k = 0; k < len; k++ )
- {
-
-diff --git opencv_contrib-master/modules/optflow/src/motempl.cpp opencv_contrib-master/modules/optflow/src/motempl.cpp
-index ec18013..452ad63 100644
---- opencv_contrib-master/modules/optflow/src/motempl.cpp
-+++ opencv_contrib-master/modules/optflow/src/motempl.cpp
-@@ -41,6 +41,7 @@
-
- #include "precomp.hpp"
- #include "opencv2/core/utility.hpp"
-+#include "opencv2/core/hal/hal.hpp"
- #include "opencl_kernels_optflow.hpp"
-
- namespace cv {
-@@ -212,7 +213,7 @@ void calcMotionGradient( InputArray _mhi, OutputArray _mask,
- float* orient_row = orient.ptr<float>(y);
- uchar* mask_row = mask.ptr<uchar>(y);
-
-- hal::fastAtan2(dY_max_row, dX_min_row, orient_row, size.width, true);
-+ cv::hal::fastAtan2(dY_max_row, dX_min_row, orient_row, size.width, true);
-
- // make orientation zero where the gradient is very small
- for( x = 0; x < size.width; x++ )
-diff --git opencv_contrib-master/modules/ximgproc/src/fgs_filter.cpp opencv_contrib-master/modules/ximgproc/src/fgs_filter.cpp
-index e89eb8f..39307e5 100644
---- opencv_contrib-master/modules/ximgproc/src/fgs_filter.cpp
-+++ opencv_contrib-master/modules/ximgproc/src/fgs_filter.cpp
-@@ -35,7 +35,7 @@
- */
-
- #include "precomp.hpp"
--#include "opencv2/hal/intrin.hpp"
-+#include "opencv2/core/hal/intrin.hpp"
- #include <vector>
-
- namespace cv {
-diff --git opencv_contrib-master/modules/xphoto/src/grayworld_white_balance.cpp opencv_contrib-master/modules/xphoto/src/grayworld_white_balance.cpp
-index 4780497..15530d3 100644
---- opencv_contrib-master/modules/xphoto/src/grayworld_white_balance.cpp
-+++ opencv_contrib-master/modules/xphoto/src/grayworld_white_balance.cpp
-@@ -40,7 +40,7 @@
- #include "opencv2/xphoto.hpp"
-
- #include "opencv2/core.hpp"
--#include "opencv2/hal/intrin.hpp"
-+#include "opencv2/core/hal/intrin.hpp"
-
- namespace cv { namespace xphoto {
-
diff --git a/media-libs/opencv/files/opencv-3.1.0-fix-ocl-declaration.patch b/media-libs/opencv/files/opencv-3.1.0-fix-ocl-declaration.patch
deleted file mode 100644
index e9a190c66324..000000000000
--- a/media-libs/opencv/files/opencv-3.1.0-fix-ocl-declaration.patch
+++ /dev/null
@@ -1,214 +0,0 @@
-From ac8dd366e4a1877e0af16961a4094496bed955f7 Mon Sep 17 00:00:00 2001
-From: Alexander Alekhin <alexander.alekhin@itseez.com>
-Date: Sun, 13 Sep 2015 21:18:47 +0300
-Subject: [PATCH] ocl: fix "off" mode
-
-diff --git opencv_contrib-master/modules/tracking/src/tldDetector.cpp opencv_contrib-master/modules/tracking/src/tldDetector.cpp
-index cbb783e..d61444b 100644
---- opencv_contrib-master/modules/tracking/src/tldDetector.cpp
-+++ opencv_contrib-master/modules/tracking/src/tldDetector.cpp
-@@ -104,6 +104,7 @@ namespace cv
- return splus / (sminus + splus);
- }
-
-+#ifdef HAVE_OPENCL
- double TLDDetector::ocl_Sr(const Mat_<uchar>& patch)
- {
- //int64 e1, e2, e3, e4;
-@@ -283,6 +284,7 @@ namespace cv
- //t = (e2 - e1) / getTickFrequency()*1000.0;
- //printf("Sr GPU: %f\n\n", t);
- }
-+#endif
-
- // Calculate Conservative similarity of the patch (NN-Model)
- double TLDDetector::Sc(const Mat_<uchar>& patch)
-@@ -337,6 +339,7 @@ namespace cv
- return splus / (sminus + splus);
- }
-
-+#ifdef HAVE_OPENCL
- double TLDDetector::ocl_Sc(const Mat_<uchar>& patch)
- {
- //int64 e1, e2, e3, e4;
-@@ -415,6 +418,7 @@ namespace cv
- return 0.0;
- return splus / (sminus + splus);
- }
-+#endif // HAVE_OPENCL
-
- // Generate Search Windows for detector from aspect ratio of initial BBs
- void TLDDetector::generateScanGrid(int rows, int cols, Size initBox, std::vector<Rect2d>& res, bool withScaling)
-@@ -565,6 +569,7 @@ namespace cv
- return true;
- }
-
-+#ifdef HAVE_OPENCL
- bool TLDDetector::ocl_detect(const Mat& img, const Mat& imgBlurred, Rect2d& res, std::vector<LabeledPatch>& patches, Size initSize)
- {
- patches.clear();
-@@ -696,6 +701,7 @@ namespace cv
- res = maxScRect;
- return true;
- }
-+#endif // HAVE_OPENCL
-
- // Computes the variance of subimage given by box, with the help of two integral
- // images intImgP and intImgP2 (sum of squares), which should be also provided.
-diff --git opencv_contrib-master/modules/tracking/src/tldDetector.hpp opencv_contrib-master/modules/tracking/src/tldDetector.hpp
-index 3e11895..1caff57 100644
---- opencv_contrib-master/modules/tracking/src/tldDetector.hpp
-+++ opencv_contrib-master/modules/tracking/src/tldDetector.hpp
-@@ -74,10 +74,12 @@ namespace cv
- inline double ensembleClassifierNum(const uchar* data);
- inline void prepareClassifiers(int rowstep);
- double Sr(const Mat_<uchar>& patch);
-- double ocl_Sr(const Mat_<uchar>& patch);
- double Sc(const Mat_<uchar>& patch);
-+#ifdef HAVE_OPENCL
-+ double ocl_Sr(const Mat_<uchar>& patch);
- double ocl_Sc(const Mat_<uchar>& patch);
- void ocl_batchSrSc(const Mat_<uchar>& patches, double *resultSr, double *resultSc, int numOfPatches);
-+#endif
-
- std::vector<TLDEnsembleClassifier> classifiers;
- Mat *posExp, *negExp;
-diff --git opencv_contrib-master/modules/tracking/src/tldModel.cpp opencv_contrib-master/modules/tracking/src/tldModel.cpp
-index 0854022..47fc32a 100644
---- opencv_contrib-master/modules/tracking/src/tldModel.cpp
-+++ opencv_contrib-master/modules/tracking/src/tldModel.cpp
-@@ -246,6 +246,7 @@ namespace cv
- dfprintf((stdout, "\n"));*/
- }
-
-+#ifdef HAVE_OPENCL
- void TrackerTLDModel::ocl_integrateAdditional(const std::vector<Mat_<uchar> >& eForModel, const std::vector<Mat_<uchar> >& eForEnsemble, bool isPositive)
- {
- int positiveIntoModel = 0, negativeIntoModel = 0, positiveIntoEnsemble = 0, negativeIntoEnsemble = 0;
-@@ -315,6 +316,7 @@ namespace cv
- dfprintf((stdout, "positiveIntoEnsemble = %d ", positiveIntoEnsemble));
- dfprintf((stdout, "\n"));*/
- }
-+#endif // HAVE_OPENCL
-
- //Push the patch to the model
- void TrackerTLDModel::pushIntoModel(const Mat_<uchar>& example, bool positive)
-diff --git opencv_contrib-master/modules/tracking/src/tldModel.hpp opencv_contrib-master/modules/tracking/src/tldModel.hpp
-index be9141a..ba7c926 100644
---- opencv_contrib-master/modules/tracking/src/tldModel.hpp
-+++ opencv_contrib-master/modules/tracking/src/tldModel.hpp
-@@ -58,7 +58,9 @@ namespace cv
- void setBoudingBox(Rect2d boundingBox){ boundingBox_ = boundingBox; }
- void integrateRelabeled(Mat& img, Mat& imgBlurred, const std::vector<TLDDetector::LabeledPatch>& patches);
- void integrateAdditional(const std::vector<Mat_<uchar> >& eForModel, const std::vector<Mat_<uchar> >& eForEnsemble, bool isPositive);
-+#ifdef HAVE_OPENCL
- void ocl_integrateAdditional(const std::vector<Mat_<uchar> >& eForModel, const std::vector<Mat_<uchar> >& eForEnsemble, bool isPositive);
-+#endif
- Size getMinSize(){ return minSize_; }
- void printme(FILE* port = stdout);
- Ptr<TLDDetector> detector;
-diff --git opencv_contrib-master/modules/tracking/src/tldTracker.cpp opencv_contrib-master/modules/tracking/src/tldTracker.cpp
-index 0f1e2f7..a5190f5 100644
---- opencv_contrib-master/modules/tracking/src/tldTracker.cpp
-+++ opencv_contrib-master/modules/tracking/src/tldTracker.cpp
-@@ -123,9 +123,11 @@ bool TrackerTLDImpl::updateImpl(const Mat& image, Rect2d& boundingBox)
-
- if (i == 1)
- {
-+#ifdef HAVE_OPENCL
- if (ocl::haveOpenCL())
- DETECT_FLG = tldModel->detector->ocl_detect(imageForDetector, image_blurred, tmpCandid, detectorResults, tldModel->getMinSize());
- else
-+#endif
- DETECT_FLG = tldModel->detector->detect(imageForDetector, image_blurred, tmpCandid, detectorResults, tldModel->getMinSize());
- }
-
-@@ -211,17 +213,21 @@ bool TrackerTLDImpl::updateImpl(const Mat& image, Rect2d& boundingBox)
- tldModel->integrateRelabeled(imageForDetector, image_blurred, detectorResults);
- //dprintf(("%d relabeled by nExpert\n", negRelabeled));
- pExpert.additionalExamples(examplesForModel, examplesForEnsemble);
-- if (ocl::haveOpenCL())
-- tldModel->ocl_integrateAdditional(examplesForModel, examplesForEnsemble, true);
-- else
-- tldModel->integrateAdditional(examplesForModel, examplesForEnsemble, true);
-+#ifdef HAVE_OPENCL
-+ if (ocl::haveOpenCL())
-+ tldModel->ocl_integrateAdditional(examplesForModel, examplesForEnsemble, true);
-+ else
-+#endif
-+ tldModel->integrateAdditional(examplesForModel, examplesForEnsemble, true);
- examplesForModel.clear(); examplesForEnsemble.clear();
- nExpert.additionalExamples(examplesForModel, examplesForEnsemble);
-
-- if (ocl::haveOpenCL())
-- tldModel->ocl_integrateAdditional(examplesForModel, examplesForEnsemble, false);
-- else
-- tldModel->integrateAdditional(examplesForModel, examplesForEnsemble, false);
-+#ifdef HAVE_OPENCL
-+ if (ocl::haveOpenCL())
-+ tldModel->ocl_integrateAdditional(examplesForModel, examplesForEnsemble, false);
-+ else
-+#endif
-+ tldModel->integrateAdditional(examplesForModel, examplesForEnsemble, false);
- }
- else
- {
-diff --git opencv_contrib-master/modules/xfeatures2d/src/surf.cpp opencv_contrib-master/modules/xfeatures2d/src/surf.cpp
-index 673817e..af5ceaf6 100644
---- opencv_contrib-master/modules/xfeatures2d/src/surf.cpp
-+++ opencv_contrib-master/modules/xfeatures2d/src/surf.cpp
-@@ -892,6 +892,7 @@ void SURF_Impl::detectAndCompute(InputArray _img, InputArray _mask,
- CV_Assert(!_img.empty() && CV_MAT_DEPTH(imgtype) == CV_8U && (imgcn == 1 || imgcn == 3 || imgcn == 4));
- CV_Assert(_descriptors.needed() || !useProvidedKeypoints);
-
-+#ifdef HAVE_OPENCL
- if( ocl::useOpenCL() )
- {
- SURF_OCL ocl_surf;
-@@ -918,6 +919,7 @@ void SURF_Impl::detectAndCompute(InputArray _img, InputArray _mask,
- return;
- }
- }
-+#endif // HAVE_OPENCL
-
- Mat img = _img.getMat(), mask = _mask.getMat(), mask1, sum, msum;
-
-diff --git opencv_contrib-master/modules/xfeatures2d/src/surf.hpp opencv_contrib-master/modules/xfeatures2d/src/surf.hpp
-index 2c4e271..cf3fda1 100644
---- opencv_contrib-master/modules/xfeatures2d/src/surf.hpp
-+++ opencv_contrib-master/modules/xfeatures2d/src/surf.hpp
-@@ -64,6 +64,7 @@ class SURF_Impl : public SURF
- bool upright;
- };
-
-+#ifdef HAVE_OPENCL
- class SURF_OCL
- {
- public:
-@@ -145,6 +146,7 @@ class SURF_OCL
-
- int status;
- };
-+#endif // HAVE_OPENCL
-
- /*
- template<typename _Tp> void copyVectorToUMat(const std::vector<_Tp>& v, UMat& um)
-diff --git opencv_contrib-master/modules/xfeatures2d/src/surf.ocl.cpp opencv_contrib-master/modules/xfeatures2d/src/surf.ocl.cpp
-index b12ebd3..3d9845d 100644
---- opencv_contrib-master/modules/xfeatures2d/src/surf.ocl.cpp
-+++ opencv_contrib-master/modules/xfeatures2d/src/surf.ocl.cpp
-@@ -43,6 +43,9 @@
- //
- //M*/
- #include "precomp.hpp"
-+
-+#ifdef HAVE_OPENCL
-+
- #include "surf.hpp"
-
- #include <cstdio>
-@@ -461,3 +464,4 @@ bool SURF_OCL::calcOrientation(UMat &keypoints)
- }
- }
-
-+#endif // HAVE_OPENCL
diff --git a/media-libs/opencv/files/opencv-3.1.0-invalid-string-usage.patch b/media-libs/opencv/files/opencv-3.1.0-invalid-string-usage.patch
deleted file mode 100644
index c9f85a758583..000000000000
--- a/media-libs/opencv/files/opencv-3.1.0-invalid-string-usage.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 9862a8bac536981c1c1a74710741fb40db4beac7 Mon Sep 17 00:00:00 2001
-From: Alexander Alekhin <alexander.alekhin@itseez.com>
-Date: Wed, 23 Sep 2015 12:44:26 +0300
-Subject: [PATCH] fix invalid String usage
-
----
- modules/tracking/src/tldDetector.cpp | 6 +++---
- modules/ximgproc/samples/live_demo.cpp | 12 ++++++------
- 2 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git opencv_contrib-master/modules/tracking/src/tldDetector.cpp opencv_contrib-master/modules/tracking/src/tldDetector.cpp
-index cbb783e..0916092 100644
---- opencv_contrib-master/modules/tracking/src/tldDetector.cpp
-+++ opencv_contrib-master/modules/tracking/src/tldDetector.cpp
-@@ -122,7 +122,7 @@ namespace cv
- ocl::Kernel k;
- ocl::ProgramSource src = ocl::tracking::tldDetector_oclsrc;
- String error;
-- ocl::Program prog(src, NULL, error);
-+ ocl::Program prog(src, String(), error);
- k.create("NCC", prog);
- if (k.empty())
- printf("Kernel create failed!!!\n");
-@@ -198,7 +198,7 @@ namespace cv
- ocl::Kernel k;
- ocl::ProgramSource src = ocl::tracking::tldDetector_oclsrc;
- String error;
-- ocl::Program prog(src, NULL, error);
-+ ocl::Program prog(src, String(), error);
- k.create("batchNCC", prog);
- if (k.empty())
- printf("Kernel create failed!!!\n");
-@@ -355,7 +355,7 @@ namespace cv
- ocl::Kernel k;
- ocl::ProgramSource src = ocl::tracking::tldDetector_oclsrc;
- String error;
-- ocl::Program prog(src, NULL, error);
-+ ocl::Program prog(src, String(), error);
- k.create("NCC", prog);
- if (k.empty())
- printf("Kernel create failed!!!\n");
-diff --git opencv_contrib-master/modules/ximgproc/samples/live_demo.cpp opencv_contrib-master/modules/ximgproc/samples/live_demo.cpp
-index dd5dc1b..8e16de3 100644
---- opencv_contrib-master/modules/ximgproc/samples/live_demo.cpp
-+++ opencv_contrib-master/modules/ximgproc/samples/live_demo.cpp
-@@ -189,7 +189,7 @@ int main()
-
- //Thread trackbar
- cv::setNumThreads(g_numberOfCPUs); //speedup filtering
-- createTrackbar("Threads", NULL, &g_numberOfCPUs, cv::getNumberOfCPUs(), changeNumberOfCpuCallback);
-+ createTrackbar("Threads", String(), &g_numberOfCPUs, cv::getNumberOfCPUs(), changeNumberOfCpuCallback);
-
- //Buttons to choose different modes
- createButton("Mode Details Enhancement", changeModeCallback, (void*)filterDetailEnhancement, QT_RADIOBOX, true);
-@@ -199,15 +199,15 @@ int main()
-
- //sliders for Details Enhancement mode
- g_filterOp = filterDetailEnhancement; //set Details Enhancement as default filter
-- createTrackbar("Detail contrast", NULL, &g_contrastBase, 200);
-- createTrackbar("Detail level" , NULL, &g_detailsLevel, 200);
-+ createTrackbar("Detail contrast", String(), &g_contrastBase, 200);
-+ createTrackbar("Detail level" , String(), &g_detailsLevel, 200);
-
- //sliders for Stylizing mode
-- createTrackbar("Style gamma", NULL, &g_edgesGamma, 300);
-+ createTrackbar("Style gamma", String(), &g_edgesGamma, 300);
-
- //sliders for every mode
-- createTrackbar("Sigma Spatial", NULL, &g_sigmaSpatial, 200);
-- createTrackbar("Sigma Color" , NULL, &g_sigmaColor, 200);
-+ createTrackbar("Sigma Spatial", String(), &g_sigmaSpatial, 200);
-+ createTrackbar("Sigma Color" , String(), &g_sigmaColor, 200);
-
- Mat rawFrame, outputFrame;
- Mat srcFrame, processedFrame;
diff --git a/media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch b/media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch
deleted file mode 100644
index af86cf98084b..000000000000
--- a/media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch
+++ /dev/null
@@ -1,392 +0,0 @@
-diff -purN a/modules/hdf/cmake/FindHDF5.cmake b/modules/hdf/cmake/FindHDF5.cmake
---- a/modules/hdf/cmake/FindHDF5.cmake 1970-01-01 01:00:00.000000000 +0100
-+++ b/modules/hdf/cmake/FindHDF5.cmake 2015-09-16 17:53:05.000000000 +0100
-@@ -0,0 +1,379 @@
-+#.rst:
-+# FindHDF5
-+# --------
-+#
-+# Find HDF5, a library for reading and writing self describing array data.
-+#
-+#
-+#
-+# This module invokes the HDF5 wrapper compiler that should be installed
-+# alongside HDF5. Depending upon the HDF5 Configuration, the wrapper
-+# compiler is called either h5cc or h5pcc. If this succeeds, the module
-+# will then call the compiler with the -show argument to see what flags
-+# are used when compiling an HDF5 client application.
-+#
-+# The module will optionally accept the COMPONENTS argument. If no
-+# COMPONENTS are specified, then the find module will default to finding
-+# only the HDF5 C library. If one or more COMPONENTS are specified, the
-+# module will attempt to find the language bindings for the specified
-+# components. The only valid components are C, CXX, Fortran, HL, and
-+# Fortran_HL. If the COMPONENTS argument is not given, the module will
-+# attempt to find only the C bindings.
-+#
-+# On UNIX systems, this module will read the variable
-+# HDF5_USE_STATIC_LIBRARIES to determine whether or not to prefer a
-+# static link to a dynamic link for HDF5 and all of it's dependencies.
-+# To use this feature, make sure that the HDF5_USE_STATIC_LIBRARIES
-+# variable is set before the call to find_package.
-+#
-+# To provide the module with a hint about where to find your HDF5
-+# installation, you can set the environment variable HDF5_ROOT. The
-+# Find module will then look in this path when searching for HDF5
-+# executables, paths, and libraries.
-+#
-+# In addition to finding the includes and libraries required to compile
-+# an HDF5 client application, this module also makes an effort to find
-+# tools that come with the HDF5 distribution that may be useful for
-+# regression testing.
-+#
-+# This module will define the following variables:
-+#
-+# ::
-+#
-+# HDF5_INCLUDE_DIRS - Location of the hdf5 includes
-+# HDF5_INCLUDE_DIR - Location of the hdf5 includes (deprecated)
-+# HDF5_DEFINITIONS - Required compiler definitions for HDF5
-+# HDF5_C_LIBRARIES - Required libraries for the HDF5 C bindings.
-+# HDF5_CXX_LIBRARIES - Required libraries for the HDF5 C++ bindings
-+# HDF5_Fortran_LIBRARIES - Required libraries for the HDF5 Fortran bindings
-+# HDF5_HL_LIBRARIES - Required libraries for the HDF5 high level API
-+# HDF5_Fortran_HL_LIBRARIES - Required libraries for the high level Fortran
-+# bindings.
-+# HDF5_LIBRARIES - Required libraries for all requested bindings
-+# HDF5_FOUND - true if HDF5 was found on the system
-+# HDF5_VERSION - HDF5 version in format Major.Minor.Release
-+# HDF5_LIBRARY_DIRS - the full set of library directories
-+# HDF5_IS_PARALLEL - Whether or not HDF5 was found with parallel IO support
-+# HDF5_C_COMPILER_EXECUTABLE - the path to the HDF5 C wrapper compiler
-+# HDF5_CXX_COMPILER_EXECUTABLE - the path to the HDF5 C++ wrapper compiler
-+# HDF5_Fortran_COMPILER_EXECUTABLE - the path to the HDF5 Fortran wrapper compiler
-+# HDF5_DIFF_EXECUTABLE - the path to the HDF5 dataset comparison tool
-+
-+#=============================================================================
-+# Copyright 2015 Axel Huebl, Helmholtz-Zentrum Dresden - Rossendorf
-+# Copyright 2009 Kitware, Inc.
-+#
-+# Distributed under the OSI-approved BSD License (the "License");
-+# see accompanying file Copyright.txt for details.
-+#
-+# This software is distributed WITHOUT ANY WARRANTY; without even the
-+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-+# See the License for more information.
-+#=============================================================================
-+# (To distribute this file outside of CMake, substitute the full
-+# License text for the above reference.)
-+
-+# This module is maintained by Will Dicharry <wdicharry@stellarscience.com>.
-+
-+include(SelectLibraryConfigurations)
-+include(FindPackageHandleStandardArgs)
-+
-+# List of the valid HDF5 components
-+set( HDF5_VALID_COMPONENTS
-+ C
-+ CXX
-+ Fortran
-+ HL
-+ Fortran_HL
-+)
-+
-+# Validate the list of find components.
-+if( NOT HDF5_FIND_COMPONENTS )
-+ set( HDF5_LANGUAGE_BINDINGS "C" )
-+else()
-+ # add the extra specified components, ensuring that they are valid.
-+ foreach( component ${HDF5_FIND_COMPONENTS} )
-+ list( FIND HDF5_VALID_COMPONENTS ${component} component_location )
-+ if( ${component_location} EQUAL -1 )
-+ message( FATAL_ERROR
-+ "\"${component}\" is not a valid HDF5 component." )
-+ else()
-+ list( APPEND HDF5_LANGUAGE_BINDINGS ${component} )
-+ endif()
-+ endforeach()
-+endif()
-+
-+# try to find the HDF5 wrapper compilers
-+find_program( HDF5_C_COMPILER_EXECUTABLE
-+ NAMES h5cc h5pcc
-+ HINTS ENV HDF5_ROOT
-+ PATH_SUFFIXES bin Bin
-+ DOC "HDF5 Wrapper compiler. Used only to detect HDF5 compile flags." )
-+mark_as_advanced( HDF5_C_COMPILER_EXECUTABLE )
-+
-+find_program( HDF5_CXX_COMPILER_EXECUTABLE
-+ NAMES h5c++ h5pc++
-+ HINTS ENV HDF5_ROOT
-+ PATH_SUFFIXES bin Bin
-+ DOC "HDF5 C++ Wrapper compiler. Used only to detect HDF5 compile flags." )
-+mark_as_advanced( HDF5_CXX_COMPILER_EXECUTABLE )
-+
-+find_program( HDF5_Fortran_COMPILER_EXECUTABLE
-+ NAMES h5fc h5pfc
-+ HINTS ENV HDF5_ROOT
-+ PATH_SUFFIXES bin Bin
-+ DOC "HDF5 Fortran Wrapper compiler. Used only to detect HDF5 compile flags." )
-+mark_as_advanced( HDF5_Fortran_COMPILER_EXECUTABLE )
-+
-+find_program( HDF5_DIFF_EXECUTABLE
-+ NAMES h5diff
-+ HINTS ENV HDF5_ROOT
-+ PATH_SUFFIXES bin Bin
-+ DOC "HDF5 file differencing tool." )
-+mark_as_advanced( HDF5_DIFF_EXECUTABLE )
-+
-+# Invoke the HDF5 wrapper compiler. The compiler return value is stored to the
-+# return_value argument, the text output is stored to the output variable.
-+macro( _HDF5_invoke_compiler language output return_value )
-+ if( HDF5_${language}_COMPILER_EXECUTABLE )
-+ exec_program( ${HDF5_${language}_COMPILER_EXECUTABLE}
-+ ARGS -show
-+ OUTPUT_VARIABLE ${output}
-+ RETURN_VALUE ${return_value}
-+ )
-+ if( ${${return_value}} EQUAL 0 )
-+ # do nothing
-+ else()
-+ message( STATUS
-+ "Unable to determine HDF5 ${language} flags from HDF5 wrapper." )
-+ endif()
-+ endif()
-+endmacro()
-+
-+# Parse a compile line for definitions, includes, library paths, and libraries.
-+macro( _HDF5_parse_compile_line
-+ compile_line_var
-+ include_paths
-+ definitions
-+ library_paths
-+ libraries )
-+
-+ # Match the include paths
-+ string( REGEX MATCHALL "-I([^\" ]+)" include_path_flags
-+ "${${compile_line_var}}"
-+ )
-+ foreach( IPATH ${include_path_flags} )
-+ string( REGEX REPLACE "^-I" "" IPATH ${IPATH} )
-+ string( REPLACE "//" "/" IPATH ${IPATH} )
-+ list( APPEND ${include_paths} ${IPATH} )
-+ endforeach()
-+
-+ # Match the definitions
-+ string( REGEX MATCHALL "-D[^ ]*" definition_flags "${${compile_line_var}}" )
-+ foreach( DEF ${definition_flags} )
-+ list( APPEND ${definitions} ${DEF} )
-+ endforeach()
-+
-+ # Match the library paths
-+ string( REGEX MATCHALL "-L([^\" ]+|\"[^\"]+\")" library_path_flags
-+ "${${compile_line_var}}"
-+ )
-+
-+ foreach( LPATH ${library_path_flags} )
-+ string( REGEX REPLACE "^-L" "" LPATH ${LPATH} )
-+ string( REPLACE "//" "/" LPATH ${LPATH} )
-+ list( APPEND ${library_paths} ${LPATH} )
-+ endforeach()
-+
-+ # now search for the library names specified in the compile line (match -l...)
-+ # match only -l's preceded by a space or comma
-+ # this is to exclude directory names like xxx-linux/
-+ string( REGEX MATCHALL "[, ]-l([^\", ]+)" library_name_flags
-+ "${${compile_line_var}}" )
-+ # strip the -l from all of the library flags and add to the search list
-+ foreach( LIB ${library_name_flags} )
-+ string( REGEX REPLACE "^[, ]-l" "" LIB ${LIB} )
-+ list( APPEND ${libraries} ${LIB} )
-+ endforeach()
-+endmacro()
-+
-+# Try to find HDF5 using an installed hdf5-config.cmake
-+if( NOT HDF5_FOUND )
-+ find_package( HDF5 QUIET NO_MODULE )
-+ if( HDF5_FOUND )
-+ set( HDF5_INCLUDE_DIRS ${HDF5_INCLUDE_DIR} )
-+ set( HDF5_LIBRARIES )
-+ set( HDF5_C_TARGET hdf5 )
-+ set( HDF5_CXX_TARGET hdf5_cpp )
-+ set( HDF5_HL_TARGET hdf5_hl )
-+ set( HDF5_Fortran_TARGET hdf5_fortran )
-+ set( HDF5_Fortran_HL_TARGET hdf5_hl_fortran )
-+ foreach( _component ${HDF5_LANGUAGE_BINDINGS} )
-+ list( FIND HDF5_VALID_COMPONENTS ${_component} _component_location )
-+ get_target_property( _comp_location ${HDF5_${_component}_TARGET} LOCATION )
-+ if( _comp_location )
-+ set( HDF5_${_component}_LIBRARY ${_comp_location} CACHE PATH
-+ "HDF5 ${_component} library" )
-+ mark_as_advanced( HDF5_${_component}_LIBRARY )
-+ list( APPEND HDF5_LIBRARIES ${HDF5_${_component}_LIBRARY} )
-+ endif()
-+ endforeach()
-+ endif()
-+endif()
-+
-+if( NOT HDF5_FOUND )
-+ _HDF5_invoke_compiler( C HDF5_C_COMPILE_LINE HDF5_C_RETURN_VALUE )
-+ _HDF5_invoke_compiler( CXX HDF5_CXX_COMPILE_LINE HDF5_CXX_RETURN_VALUE )
-+ _HDF5_invoke_compiler( Fortran HDF5_Fortran_COMPILE_LINE HDF5_Fortran_RETURN_VALUE )
-+
-+ # seed the initial lists of libraries to find with items we know we need
-+ set( HDF5_C_LIBRARY_NAMES_INIT hdf5 )
-+ set( HDF5_HL_LIBRARY_NAMES_INIT hdf5_hl ${HDF5_C_LIBRARY_NAMES_INIT} )
-+ set( HDF5_CXX_LIBRARY_NAMES_INIT hdf5_cpp ${HDF5_C_LIBRARY_NAMES_INIT} )
-+ set( HDF5_Fortran_LIBRARY_NAMES_INIT hdf5_fortran
-+ ${HDF5_C_LIBRARY_NAMES_INIT} )
-+ set( HDF5_Fortran_HL_LIBRARY_NAMES_INIT hdf5hl_fortran
-+ ${HDF5_Fortran_LIBRARY_NAMES_INIT} )
-+
-+ foreach( LANGUAGE ${HDF5_LANGUAGE_BINDINGS} )
-+ if( HDF5_${LANGUAGE}_COMPILE_LINE )
-+ _HDF5_parse_compile_line( HDF5_${LANGUAGE}_COMPILE_LINE
-+ HDF5_${LANGUAGE}_INCLUDE_FLAGS
-+ HDF5_${LANGUAGE}_DEFINITIONS
-+ HDF5_${LANGUAGE}_LIBRARY_DIRS
-+ HDF5_${LANGUAGE}_LIBRARY_NAMES
-+ )
-+
-+ # take a guess that the includes may be in the 'include' sibling
-+ # directory of a library directory.
-+ foreach( dir ${HDF5_${LANGUAGE}_LIBRARY_DIRS} )
-+ list( APPEND HDF5_${LANGUAGE}_INCLUDE_FLAGS ${dir}/../include )
-+ endforeach()
-+ endif()
-+
-+ # set the definitions for the language bindings.
-+ list( APPEND HDF5_DEFINITIONS ${HDF5_${LANGUAGE}_DEFINITIONS} )
-+
-+ # find the HDF5 include directories
-+ if(${LANGUAGE} MATCHES "Fortran")
-+ set(HDF5_INCLUDE_FILENAME hdf5.mod)
-+ else()
-+ set(HDF5_INCLUDE_FILENAME hdf5.h)
-+ endif()
-+
-+ find_path( HDF5_${LANGUAGE}_INCLUDE_DIR ${HDF5_INCLUDE_FILENAME}
-+ HINTS
-+ ${HDF5_${LANGUAGE}_INCLUDE_FLAGS}
-+ ENV
-+ HDF5_ROOT
-+ PATHS
-+ $ENV{HOME}/.local/include
-+ PATH_SUFFIXES
-+ include
-+ Include
-+ )
-+ mark_as_advanced( HDF5_${LANGUAGE}_INCLUDE_DIR )
-+ list( APPEND HDF5_INCLUDE_DIRS ${HDF5_${LANGUAGE}_INCLUDE_DIR} )
-+
-+ set( HDF5_${LANGUAGE}_LIBRARY_NAMES
-+ ${HDF5_${LANGUAGE}_LIBRARY_NAMES_INIT}
-+ ${HDF5_${LANGUAGE}_LIBRARY_NAMES} )
-+
-+ # find the HDF5 libraries
-+ foreach( LIB ${HDF5_${LANGUAGE}_LIBRARY_NAMES} )
-+ if( UNIX AND HDF5_USE_STATIC_LIBRARIES )
-+ # According to bug 1643 on the CMake bug tracker, this is the
-+ # preferred method for searching for a static library.
-+ # See http://www.cmake.org/Bug/view.php?id=1643. We search
-+ # first for the full static library name, but fall back to a
-+ # generic search on the name if the static search fails.
-+ set( THIS_LIBRARY_SEARCH_DEBUG lib${LIB}d.a ${LIB}d )
-+ set( THIS_LIBRARY_SEARCH_RELEASE lib${LIB}.a ${LIB} )
-+ else()
-+ set( THIS_LIBRARY_SEARCH_DEBUG ${LIB}d )
-+ set( THIS_LIBRARY_SEARCH_RELEASE ${LIB} )
-+ endif()
-+ find_library( HDF5_${LIB}_LIBRARY_DEBUG
-+ NAMES ${THIS_LIBRARY_SEARCH_DEBUG}
-+ HINTS ${HDF5_${LANGUAGE}_LIBRARY_DIRS}
-+ ENV HDF5_ROOT
-+ PATH_SUFFIXES lib Lib )
-+ find_library( HDF5_${LIB}_LIBRARY_RELEASE
-+ NAMES ${THIS_LIBRARY_SEARCH_RELEASE}
-+ HINTS ${HDF5_${LANGUAGE}_LIBRARY_DIRS}
-+ ENV HDF5_ROOT
-+ PATH_SUFFIXES lib Lib )
-+ select_library_configurations( HDF5_${LIB} )
-+ list(APPEND HDF5_${LANGUAGE}_LIBRARIES ${HDF5_${LIB}_LIBRARY})
-+ endforeach()
-+ list( APPEND HDF5_LIBRARY_DIRS ${HDF5_${LANGUAGE}_LIBRARY_DIRS} )
-+
-+ # Append the libraries for this language binding to the list of all
-+ # required libraries.
-+ list(APPEND HDF5_LIBRARIES ${HDF5_${LANGUAGE}_LIBRARIES})
-+ endforeach()
-+
-+ # We may have picked up some duplicates in various lists during the above
-+ # process for the language bindings (both the C and C++ bindings depend on
-+ # libz for example). Remove the duplicates. It appears that the default
-+ # CMake behavior is to remove duplicates from the end of a list. However,
-+ # for link lines, this is incorrect since unresolved symbols are searched
-+ # for down the link line. Therefore, we reverse the list, remove the
-+ # duplicates, and then reverse it again to get the duplicates removed from
-+ # the beginning.
-+ macro( _remove_duplicates_from_beginning _list_name )
-+ list( REVERSE ${_list_name} )
-+ list( REMOVE_DUPLICATES ${_list_name} )
-+ list( REVERSE ${_list_name} )
-+ endmacro()
-+
-+ if( HDF5_INCLUDE_DIRS )
-+ _remove_duplicates_from_beginning( HDF5_INCLUDE_DIRS )
-+ endif()
-+ if( HDF5_LIBRARY_DIRS )
-+ _remove_duplicates_from_beginning( HDF5_LIBRARY_DIRS )
-+ endif()
-+
-+ # If the HDF5 include directory was found, open H5pubconf.h to determine if
-+ # HDF5 was compiled with parallel IO support
-+ set( HDF5_IS_PARALLEL FALSE )
-+ set( HDF5_VERSION "" )
-+ foreach( _dir IN LISTS HDF5_INCLUDE_DIRS )
-+ foreach(_hdr "${_dir}/H5pubconf.h" "${_dir}/H5pubconf-64.h" "${_dir}/H5pubconf-32.h")
-+ if( EXISTS "${_hdr}" )
-+ file( STRINGS "${_hdr}"
-+ HDF5_HAVE_PARALLEL_DEFINE
-+ REGEX "HAVE_PARALLEL 1" )
-+ if( HDF5_HAVE_PARALLEL_DEFINE )
-+ set( HDF5_IS_PARALLEL TRUE )
-+ endif()
-+ unset(HDF5_HAVE_PARALLEL_DEFINE)
-+
-+ file( STRINGS "${_hdr}"
-+ HDF5_VERSION_DEFINE
-+ REGEX "^[ \t]*#[ \t]*define[ \t]+H5_VERSION[ \t]+" )
-+ if( "${HDF5_VERSION_DEFINE}" MATCHES
-+ "H5_VERSION[ \t]+\"([0-9]+\\.[0-9]+\\.[0-9]+).*\"" )
-+ set( HDF5_VERSION "${CMAKE_MATCH_1}" )
-+ endif()
-+ unset(HDF5_VERSION_DEFINE)
-+ endif()
-+ endforeach()
-+ endforeach()
-+ set( HDF5_IS_PARALLEL ${HDF5_IS_PARALLEL} CACHE BOOL
-+ "HDF5 library compiled with parallel IO support" )
-+ mark_as_advanced( HDF5_IS_PARALLEL )
-+
-+ # For backwards compatibility we set HDF5_INCLUDE_DIR to the value of
-+ # HDF5_INCLUDE_DIRS
-+ if( HDF5_INCLUDE_DIRS )
-+ set( HDF5_INCLUDE_DIR "${HDF5_INCLUDE_DIRS}" )
-+ endif()
-+
-+endif()
-+
-+find_package_handle_standard_args( HDF5
-+ REQUIRED_VARS HDF5_LIBRARIES HDF5_INCLUDE_DIRS
-+ VERSION_VAR HDF5_VERSION
-+)
-+
-diff -purN a/modules/hdf/CMakeLists.txt b/modules/hdf/CMakeLists.txt
---- a/modules/hdf/CMakeLists.txt 2015-12-17 17:11:31.000000000 +0000
-+++ b/modules/hdf/CMakeLists.txt 2016-09-19 15:24:47.958650311 +0100
-@@ -1,4 +1,4 @@
--set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR})
-+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_LIST_DIR}/cmake)
-
- find_package(HDF5)
- if(HDF5_FOUND)