summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-05-25 21:23:46 +0200
committerAmy Liffey <amynka@gentoo.org>2018-05-25 21:26:03 +0200
commitf3c8fe50642f04ec8434ee96f153689cedb8ec5c (patch)
tree34fb7a1f94b6578562ac3ddd366450cb994584bc /media-libs/opencv/files
parentdev-db/percona-toolkit: correctly compute slave lag for pt-slave-delay (diff)
downloadgentoo-f3c8fe50642f04ec8434ee96f153689cedb8ec5c.tar.gz
gentoo-f3c8fe50642f04ec8434ee96f153689cedb8ec5c.tar.bz2
gentoo-f3c8fe50642f04ec8434ee96f153689cedb8ec5c.zip
media-libs/opencv: version bump 3.4.1
Closes: https://bugs.gentoo.org/642800 Closes: https://bugs.gentoo.org/633900 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/opencv/files')
-rw-r--r--media-libs/opencv/files/opencv-3.4.0-disable-download.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/opencv/files/opencv-3.4.0-disable-download.patch b/media-libs/opencv/files/opencv-3.4.0-disable-download.patch
new file mode 100644
index 000000000000..245ad3b3d028
--- /dev/null
+++ b/media-libs/opencv/files/opencv-3.4.0-disable-download.patch
@@ -0,0 +1,29 @@
+--- a/CMakeLists.txt 2018-05-13 20:47:11.635871328 +0200
++++ b/CMakeLists.txt 2018-05-13 20:47:49.289872617 +0200
+@@ -187,6 +187,7 @@
+ # ----------------------------------------------------------------------------
+
+ OCV_OPTION(OPENCV_ENABLE_NONFREE "Enable non-free algorithms" OFF)
++OCV_OPTION(ENABLE_DOWNLOAD "Enable download during configure" ON)
+
+ # 3rd party libs
+ OCV_OPTION(BUILD_ZLIB "Build zlib from source" WIN32 OR APPLE)
+
+--- a/cmake/OpenCVDownload.cmake 2018-05-13 21:22:14.966943336 +0200
++++ b/cmake/OpenCVDownload.cmake 2018-05-13 21:23:15.959945424 +0200
+@@ -32,6 +32,7 @@
+
+
+ function(ocv_download)
++ if(ENABLE_DOWNLOAD)
+ cmake_parse_arguments(DL "UNPACK;RELATIVE_URL" "FILENAME;HASH;DESTINATION_DIR;ID;STATUS" "URL" ${ARGN})
+
+ macro(ocv_download_log)
+@@ -236,4 +237,7 @@
+ if(OCV_DOWNLOAD_HASH_NAME)
+ set(${OCV_DOWNLOAD_HASH_NAME} "${DL_HASH}" CACHE INTERNAL "")
+ endif()
++ else()
++ message( "Download was disabled during configure phase by ENABLE_DOWNLOAD=OFF" )
++ endif()
+ endfunction()